Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

ACC2000: Table Filter Is Lost After Importing Table


View products that this article applies to.

This article was previously published under Q207591

↑ Back to the top


Symptoms

Novice: Requires knowledge of the user interface on single-user computers.

When you import a table with its Filter property set into a new Microsoft Access database, you find that the filter is no longer available. When you open the table in the new database, the Filter button is dimmed.

↑ Back to the top


Cause

Table filters are not imported with the table.

↑ Back to the top


More information

Steps to Reproduce Behavior

1.Open the sample database Northwind.mdb.
2.In the Database window, click Tables under Objects. Click the Categories table, and then click Open.
3.On the Records menu, point to Filter, and then click Filter By Form.
4.Enter the number 3 into the CategoryID field.
5.On the Filter menu, click Apply Filter/Sort.

Note that the Categories table displays only records that match the filter.
6.Close the Categories table. When prompted to save the changes to the design of the table, click Yes.
7.Close the sample database Northwind.mdb.
8.In the Database window, click New on the File menu, and then create a blank database.
9.On the File menu, point to Get External Data, then click Import.
10.Select the Northwind database and click Import. If you installed Access to the default location, the path is C:\Program Files\Microsoft Office\Office\Samples\Northwind.mdb.
11.Select the Categories table and click OK to import the table.
12.Open the Categories table.
Note that the Apply Filter button, on the Table Datasheet toolbar, is not available in the Categories table. On the Records menu, you can click Apply Filter/Sort; however, there is no criteria for the filter.

↑ Back to the top


Keywords: KB207591, kbprb

↑ Back to the top

Article Info
Article ID : 207591
Revision : 2
Created on : 7/16/2004
Published on : 7/16/2004
Exists online : False
Views : 300