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FIX: A valid EDIFACT message that contains a "+" character in the data element is suspended when you use the EDI receive pipeline in BizTalk Server


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You use the EDI Receive pipeline in Microsoft BizTalk Server 2006 R2, Microsoft BizTalk Server 2009 or Microsoft BizTalk Server 2010 to receive Electronic Data Interchange For Administration, Commerce and Transport (EDIFACT) messages.
  • You receive a valid EDIFACT message that meets the following conditions:
    • The message uses the UNOA syntax version.
    • The "+" character is used as a separator.
    • One data element contains the "+" character as part of the data, and the "+" character is prefaced with a release character. For example, one data element is displayed as the following:
      Z04:SAMPLE:?+8888888888
      Note A release character is a character that is used to restore the original meaning of any character that is used as a syntactical separator. Usually, a question mark (?) is used as a release character. If you use BizTalk Server 2009, the Event Source and Event Category in above events are �BizTalk Server 2009�.
In this scenario, the valid EDIFACT message is suspended unexpectedly. Additionally, an error message that resembles the following is logged in the Application log:
Event Type: Error
Event Source: BizTalk Server 2006 EDI
Event Category: None
Event ID: 8118
Description:
Error encountered during parsing. The Edifact transaction set with id '<transaction set id>' contained in interchange (without group) with id '<interchange id>', with sender id '<sender id>', receiver id '<receiver id>' is being suspended with following errors:
...

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Cause

This issue occurs because of an error in the EDI Receive pipeline. The EDI Receive pipeline identifies a '+' character that appears in an EDIFACT message as invalid.

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Resolution

Cumulative update information

BizTalk Server 2010


For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2497789 Cumulative update package 1 for BizTalk 2010

BizTalk Server 2009

The hotfix that resolves this issue is included in cumulative update package 2 for BizTalk Server 2009.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:

2497794 Cumulative update package 2 for BizTalk Server 2009

The hotfix that resolves this problem is included in cumulative update package 2 for BizTalk Server 2006 R2 SP1.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2211420 Cumulative update package 2 for BizTalk Server 2006 R2 Service Pack 1
For more information about BizTalk Server 2006 R2 SP1 hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
974563 List of Microsoft BizTalk Server hot fixes that are included in BizTalk Server 2006 R2 Service Pack 1
For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
2003907 Information on BizTalk Server hotfixes

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbqfe, kbfix, kbbiztalk2006r2presp2fix, kbbtspipeline, kbsurveynew, kbexpertiseadvanced, kbbiztalk2009presp1fix, KB2065966

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Article Info
Article ID : 2065966
Revision : 5
Created on : 5/23/2011
Published on : 5/23/2011
Exists online : False
Views : 518