Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

How to submit form results to multiple files or e-mail recipients in FrontPage 2000 and in FrontPage 2002


View products that this article applies to.

This article was previously published under Q205756
For a Microsoft FrontPage 98 version of this article, see 187249 (http://support.microsoft.com/kb/187249/ ) .
For a Microsoft FrontPage 98 version of this article, see 187249 (http://support.microsoft.com/kb/187249/ ) .

↑ Back to the top


Summary

In Microsoft FrontPage 2000 and in Microsoft FrontPage 2002, you can save a file to two or more separate file locations or in two or more file formats. You can also send a file to multiple e-mail recipients or save different form fields in different locations. To accomplish any of these tasks, you need to use one or more custom confirmation pages that contain the same form field names as the original feedback form. This article describes the steps you need to create the web pages with a custom confirmation when you submit form results to multiple files or email recipients.

Note Make sure that Front Page Server extensions have been configured to send email from your web pages.

Submit Form Results to Multiple Files or Email Recipients

You can send a file to multiple e-mail recipients using a custom form, or save form fields in separate locations, or save the results in more than two files.

If you want to specify a single file and e-mail recipient for the results of a form, type the information in the Form Properties dialog box. If you want to specify an optional second file to save the results to, click Options in the Form Properties dialog box.

Copy Page with Form

  1. Open an exisiting Web or create a new Web.
  2. On the File menu, point to New, and then click Page.
  3. On the Insert menu, point to Form, and then click One-line Text Box.
  4. On the File menu, click Save. Save the file as Page1.htm.
  5. Select the form, and then click Copy on the Edit menu.

    NOTE: Copy only the form.
  6. On the File menu, point to New, and then click Page.
  7. On the Edit menu, click Paste.
  8. On the File menu, click Save. Save the file as Page2.htm.

Create Custom Confirmation Page

  1. After the first page has been created then switch to Page1.htm.
  2. Right-click the form and click Form Properties on the menu that appears.
  3. In the Form Properties dialog box, click Send to.
  4. In the File name box, type the name of the file you want to send results to.
  5. In the Email address box, type the e-mail address of the recipient.
  6. Click Options.
  7. Click the Confirmation Page tab.
  8. In the URL of confirmation page section, click Browse.
  9. Select Page2.htm and click OK.
  10. Click OK two more times.

    Note: If you want to save part of the data in the file or send part of it to an e-mail recipient, click the Saved Fields tab and remove any fields you do not want to save in the results file.
  11. Create a confirmation page with a confirmation message and acknowledgment. To do this, point to New on the File menu, and then click Page. Add your message for confirmation, then Save as Confirm.htm.
  12. Close the page.

Use Custom Confirmation Page with Forms

  1. Open Page2.htm.
  2. Right-click the form and click Form Properties on the menu that appears.
  3. Click the Confirmation Page tab.
  4. In the URL of confirmation page section, click Browse.
  5. Select the confirmation page, Confirm.htm, and click OK.
  6. Click OK two more times. NOTE: This will create a daisy-chain effect for your confirmation pages.



↑ Back to the top


Keywords: KB205756, kbwebpublishing, kbopenfile, kbemail, kbforms, kbwebserver, kbhowtomaster

↑ Back to the top

Article Info
Article ID : 205756
Revision : 3
Created on : 4/4/2006
Published on : 4/4/2006
Exists online : False
Views : 341