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FP2000: Error Message: HTTP Code 500 While Creating Web, Browsing Page with Image, Web Components


View products that this article applies to.

This article was previously published under Q205271

For a Microsoft FrontPage 98 version of this article, see 194545 (http://support.microsoft.com/kb/194545/EN-US/ ) .
For a Microsoft FrontPage 97 version of this article, see 143097 (http://support.microsoft.com/kb/143097/EN-US/ ) .

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Symptoms

In Microsoft FrontPage, you may receive the following error message:
Server Error. This server has encountered an internal error which prevents it from fulfilling your request. The most likely cause is a misconfiguration. Please ask the administrator to look for messages in the server's error log.
This error message occurs in one of the following circumstances:
  • You browse a page that contains an image map or a WebBot.

    -or-
  • You create a new Web.

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Cause

This problem may occur for one of the following reasons:
  • If you are using Microsoft Personal Web Server, FrontPage is not able to execute Shtml.dll.

    -or-
  • If you are using FrontPage Personal Web Server, FrontPage is not able to execute Shtml.exe.

    -or-
  • FrontPage cannot access the server through the extensions.

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Resolution

To work around this problem, use the method appropriate for your situation.

Method 1: Check Error Logs and Memory

Check the error logs for "out of memory" errors, and then verify the amount of physical and virtual memory installed on your computer.

If you are using the FrontPage Personal Web Server, the error logs will be located in the \FrontPage Webs\Server\Logs folder.

If you are using Microsoft Personal Web Server, the error logs will be located in the \Windows folder.

You should have 16 megabytes (MB) of RAM in order to run the FrontPage Personal Web Server or Microsoft Personal Web Server. You should also set a permanent swap file that is at least 20 MB in size.

Method 2: Check Configuration Settings

If you have changed the default content folder for the FrontPage Personal Web Server, check the following:
  • The definition of the DocumentRoot in the Srm.cnf file.
  • The following settings in the Srm.cnf:
    WinScriptAlias _vti_bin/ c:\FrontPage/Webs\content\_vti_bin
If you have changed the default content folder for the Microsoft Personal Web Server, check the following:

Version 1.0 or 2.0:
  • The Document Root is defined in the Directories tab of the Internet Services Administrator. To access the Internet Services Administrator, follow these steps:
    1. On the Windows Start menu, point to Settings, and then click Control Panel.
    2. Double-click the Personal Web Server icon.
    3. Click the Administration tab.
    4. Click Administration.
Version 4.0
  1. Locate pwstray.exe, and double-click it
  2. Click Advanced Navigation

Method 3: Check the Shtml.exe or Shtml.dll File and File Size

If you have not changed the default content folder, check the following:
  • If you are using FrontPage Personal Web Server, verify that the \_vti_bin\shtml.exe file exists and that its file size is greater than zero. This file is located in the DocumentRoot folder.
  • If you are using Microsoft Personal Web Server, verify that the \_vti_bin\shtml.dll file exists and that its file size is greater than zero. This file is located by default in \Program Files\Common Files\Microsoft Shared\Web Server Extensions\40
NOTE: You can use these same methods to troubleshoot this type of error on other Web servers. Check your Web server's documentation for the proper location of server-generated error logs and the proper method for changing DocumentRoot and marking directories as executable.

Method 4: Check Whether the Server is Running

Verify that the server is running. If it is not running, start it. Confirm it is started by browsing to the URL for the HTTP server.

Method 5: Verify the Server Extensions Are Installed

Verify that the server extensions have been installed on the server. To do this, follow these steps:
  1. To start the Server Extensions Administrator, click the Windows Start menu, point to Programs, point to Microsoft Office Tools, and then click Server Extensions Administrator.
  2. Click to expand FrontPage Server Extensions.
  3. Right-click your machine name and click Task. Check the Server Extensions
  4. Confirm that the server information is correct.

Method 6: Install the FrontPage Server Extensions

Install the FrontPage Server Extensions. You can download the FrontPage Server Extensions from the following Microsoft World Wide Web site:

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Keywords: KB205271, kbprb

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Article Info
Article ID : 205271
Revision : 3
Created on : 7/2/2007
Published on : 7/2/2007
Exists online : False
Views : 375