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You are prompted for credentials when you access a resource in a Windows Server 2008 SP2-based or Windows Server 2008 R2 SP1-based domain if you use a smart card


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You deploy a read/write domain controller in a central office. And you deploy a read-only domain controller (RODC) in a branch office that is located at a different location from the central office. Both domain controllers are running Windows Server 2008 Service Pack 2 (SP2) or Windows Server 2008 R2 Service Pack 1 (SP1).
  • You cache only the passwords of the user accounts that are for the branch office on the RODC. The related passwords of the computer accounts are not cached on the RODC.
  • In the branch office, you log on to the domain by using a smart card.
In this scenario, all NTLM authentication requests from user accounts fail. Additionally, you are prompted to input your user name and password when you try to access a resource in the domain. For example, you are prompted for credentials when you try to access a shared file or a web server by using the IP address of the computer that hosts the shared file or the web server.

Note Kerberos authentication requests from user accounts in the branch office succeed. Therefore, you are not prompted when you try to access the shared file or the web server by using the computer name that hosts the shared file.

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Cause

This issue occurs because read/write domain controller does not return the NTLM user passwords for user accounts to the RODC. Therefore, all NTLM authentication requests fail.

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Resolution

To resolve this issue, install this hotfix on the read/write domain controller that is running Windows Server 2008 Service Pack 2 (SP2) or Windows Server 2008 R2 Service Pack 1 (SP1).

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 Service Pack 2 (SP2) or or Windows Server 2008 R2 Service Pack 1 (SP1) and have the Active Directory Domain Services (AD DS) role installed.

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008
For more information about how to obtain a Windows 7 or a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 file information notes
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600 2 . 22xxxWindows Vista and Windows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Kdcsvc.dll6.0.6002.22405313,34414-May-201018:14x86
Kdcsvc.mofNot applicable5,30003-Apr-200921:47Not applicable
For all supported x64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Kdcsvc.dll6.0.6002.22405407,04014-May-201018:21x64
Kdcsvc.mofNot applicable5,30003-Apr-200921:07Not applicable
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760 1 . 21xxxWindows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Kdcsvc.dll6.1.7601.21897431,10413-Jan-201208:10x64
Kdcsvc.mofNot Applicable5,30005-Nov-201002:14Not Applicable

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Workaround

Workaround for Windows Server 2008 and for Windows Server 2008 R2

To work around this issue, manually cache both the passwords of user accounts and the passwords of computer accounts on the RODC.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008

Additional files for all supported x86-based versions of Windows Server 2008
File nameUpdate.mum
File versionNot applicable
File size2,261
Date (UTC)18-May-2010
Time (UTC)04:49
PlatformNot applicable

File nameX86_1cedcb653984066f13847ab2b0d04129_31bf3856ad364e35_6.0.6002.22405_none_fedca755150af31d.manifest
File versionNot applicable
File size720
Date (UTC)18-May-2010
Time (UTC)04:49
PlatformNot applicable

File nameX86_microsoft-windows-k..distribution-center_31bf3856ad364e35_6.0.6002.22405_none_8e2ce3d9aa804577.manifest
File versionNot applicable
File size42,276
Date (UTC)14-May-2010
Time (UTC)19:56
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Server 2008
File nameAmd64_2ad761ee8fa232916ecbb424f975d388_31bf3856ad364e35_6.0.6002.22405_none_1cb663eafce86ce1.manifest
File versionNot applicable
File size724
Date (UTC)18-May-2010
Time (UTC)04:49
PlatformNot applicable

File nameAmd64_microsoft-windows-k..distribution-center_31bf3856ad364e35_6.0.6002.22405_none_ea4b7f5d62ddb6ad.manifest
File versionNot applicable
File size42,320
Date (UTC)14-May-2010
Time (UTC)20:01
PlatformNot applicable

File nameUpdate.mum
File versionNot applicable
File size2,277
Date (UTC)18-May-2010
Time (UTC)04:49
PlatformNot applicable

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_afdb7e675badbe7eda7573ec572c5276_31bf3856ad364e35_6.1.7601.21897_none_b1505f48f5e5b23e.manifest
File versionNot Applicable
File size724
Date (UTC)13-Jan-2012
Time (UTC)15:28
PlatformNot Applicable
File nameAmd64_microsoft-windows-k..distribution-center_31bf3856ad364e35_6.1.7601.21897_none_ea13efd4c43c32d2.manifest
File versionNot Applicable
File size35,825
Date (UTC)13-Jan-2012
Time (UTC)09:00
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,706
Date (UTC)13-Jan-2012
Time (UTC)15:28
PlatformNot Applicable

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Keywords: KB2029058, kbexpertiseadvanced, kbsurveynew, kbfix, kbHotfixServer, kbqfe, kbautohotfix

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Article Info
Article ID : 2029058
Revision : 2
Created on : 2/16/2012
Published on : 2/16/2012
Exists online : False
Views : 267