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The applications that use the TDI driver for network traffic may stop responding in Windows Server 2008 R2 or in Windows 7


View products that this article applies to.

Symptoms

On a computer that is running Windows Server 2008 R2 or Windows 7, any application that uses the Transport Driver Interface (TDI) driver for network traffic may stop responding.

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Cause

This issue occurs because of a race condition in the TDI extension driver (Tdx.sys). When the TCP Synchronize (SYN) packet and the Address object deactivation are received at the same time, Tdx.sys driver returns without any action if the Tdx.sys driver detects that the Address object is deactivated. Therefore, the reference to the TCP listener is not cleaned up. This behavior causes some threads to be stuck waiting for TCP. Therefore, the application stops responding.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows 7.

Registry information

To use the hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    0.
    21xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Tdx.sys6.1.7600.2105074,75210-Sep-201102:19x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Tdx.sys6.1.7600.21050101,37610-Sep-201102:46x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Tdx.sys6.1.7600.21050236,03210-Sep-201101:55IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about the SYN packet, view the following Microsoft website:For more information about the TDI, view the following Microsoft Tech website:For more information about Windows 2000 network architecture, view the following Microsoft Tech website:For more information about the Address object, view the following Microsoft website:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot Applicable
File size1,880
Date (UTC)12-Sep-2011
Time (UTC)10:07
PlatformNot Applicable
File nameX86_4f2273f1d505e083d7858735735b14c9_31bf3856ad364e35_6.1.7600.21050_none_987f60c6667a34d3.manifest
File versionNot Applicable
File size702
Date (UTC)12-Sep-2011
Time (UTC)10:07
PlatformNot Applicable
File nameX86_microsoft-windows-tdi-over-tcpip_31bf3856ad364e35_6.1.7600.21050_none_eab90b2c56733071.manifest
File versionNot Applicable
File size2,924
Date (UTC)10-Sep-2011
Time (UTC)05:00
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_09f8a2d8c1b4ed8ed5ef5aafb4c794ea_31bf3856ad364e35_6.1.7600.21050_none_a4fa2ab31eb9d559.manifest
File versionNot Applicable
File size706
Date (UTC)12-Sep-2011
Time (UTC)10:07
PlatformNot Applicable
File nameAmd64_microsoft-windows-tdi-over-tcpip_31bf3856ad364e35_6.1.7600.21050_none_46d7a6b00ed0a1a7.manifest
File versionNot Applicable
File size2,926
Date (UTC)10-Sep-2011
Time (UTC)06:05
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,114
Date (UTC)12-Sep-2011
Time (UTC)10:07
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_7cd8ec45e623e2a1807544075545bc24_31bf3856ad364e35_6.1.7600.21050_none_20291ce4506b3276.manifest
File versionNot Applicable
File size704
Date (UTC)12-Sep-2011
Time (UTC)10:07
PlatformNot Applicable
File nameIa64_microsoft-windows-tdi-over-tcpip_31bf3856ad364e35_6.1.7600.21050_none_eabaaf225671396d.manifest
File versionNot Applicable
File size2,925
Date (UTC)10-Sep-2011
Time (UTC)05:55
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,690
Date (UTC)12-Sep-2011
Time (UTC)10:07
PlatformNot Applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexc2ksp3rtmpublic

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Article Info
Article ID : 2028827
Revision : 1
Created on : 1/7/2017
Published on : 10/13/2011
Exists online : False
Views : 323