Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"0x00000050" Stop error message occurs when you use multiple volume managers in Windows Server 2008 or in Windows Server 2008 R2


View products that this article applies to.

Not sure if this is the right fix? We've added this issue to our memory dump diagnostic which can confirm.

↑ Back to the top


Symptoms

Consider the following scenario:
  • You configure a failover cluster on some computers that are running Windows Server 2008 or Windows Server 2008 R2.
  • You install at least one third-party volume manager on these cluster nodes. For example, you install the volume manager from Vertias.
  • You fail over some disk resource from one node to the other node.
In this scenario, you receive the following Stop error message on the two cluster nodes that are involved in the failover:
Stop 0x00000050 (parameter1, 0, parameter3, parameter4)

PAGE_FAULT_IN_NONPAGED_AREA
Note
  • The parameters in this Stop error message vary, depending on the configuration of the computer.
  • Not all "0x00000050" Stop error messages are caused by this problem.
  • The node that has the disk resource encounters this Stop code error message first. After a while, the node that receives the disk resource encounters this Stop code error message.

↑ Back to the top


Cause

This issue occurs because of a timing issue in Partition Manager (Partmgr.sys) if more than one volume manager are installed. When this timing issue occurs, some disk device objects and some file objects in memory are incorrectly freed.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Server 2008 Service Pack 2
  • Windows Server 2008 R2


For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 file information notes
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    2.
    22xxx
    Windows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Partmgr.sys6.0.6002.2240553,12814-May-201018:53x86
For all supported x64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Partmgr.sys6.0.6002.2240572,06414-May-201018:59x64
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Partmgr.sys6.0.6002.22405153,99214-May-201018:36IA-64
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Partmgr.mofNot applicable1,94510-Jun-200920:44Not applicable
Partmgr.sys6.1.7600.2075775,13617-Jul-201008:11x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Partmgr.mofNot applicable1,94510-Jun-200920:49Not applicable
Partmgr.sys6.1.7600.20757169,35217-Jul-201006:52IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008

Additional files for all supported x86-based versions of Windows Server 2008
File nameUpdate.mum
File versionNot applicable
File size3,078
Date (UTC)18-May-2010
Time (UTC)04:49
PlatformNot applicable
File nameX86_89389cb3d770c3c0c03b0ba313fee8f6_31bf3856ad364e35_6.0.6002.22405_none_2d7aeb4d81e63f66.manifest
File versionNot applicable
File size704
Date (UTC)18-May-2010
Time (UTC)04:49
PlatformNot applicable
File nameX86_microsoft-windows-partitionmanager_31bf3856ad364e35_6.0.6002.22405_none_e4112f14d0aef31e.manifest
File versionNot applicable
File size9,532
Date (UTC)14-May-2010
Time (UTC)20:00
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Server 2008
File nameAmd64_22ab313fc80e6a5c44ba5ffc92a3847a_31bf3856ad364e35_6.0.6002.22405_none_99e3038c4e69dbbd.manifest
File versionNot applicable
File size708
Date (UTC)18-May-2010
Time (UTC)04:49
PlatformNot applicable
File nameAmd64_microsoft-windows-partitionmanager_31bf3856ad364e35_6.0.6002.22405_none_402fca98890c6454.manifest
File versionNot applicable
File size9,542
Date (UTC)14-May-2010
Time (UTC)20:04
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size3,102
Date (UTC)18-May-2010
Time (UTC)04:49
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_ea6daab3e52f5da82b5bec78be795a69_31bf3856ad364e35_6.0.6002.22405_none_0320580d4e85f187.manifest
File versionNot applicable
File size706
Date (UTC)18-May-2010
Time (UTC)04:49
PlatformNot applicable
File nameIa64_microsoft-windows-partitionmanager_31bf3856ad364e35_6.0.6002.22405_none_e412d30ad0acfc1a.manifest
File versionNot applicable
File size9,537
Date (UTC)14-May-2010
Time (UTC)19:23
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,255
Date (UTC)18-May-2010
Time (UTC)04:49
PlatformNot applicable

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_d7775d3067064348de9be1c3dafdb679_31bf3856ad364e35_6.1.7600.20757_none_eba7c882f01fa396.manifest
File versionNot applicable
File size708
Date (UTC)19-Jul-2010
Time (UTC)13:08
PlatformNot applicable
File nameAmd64_microsoft-windows-partitionmanager_31bf3856ad364e35_6.1.7600.20757_none_3e3d1807ed240d54.manifest
File versionNot applicable
File size8,992
Date (UTC)17-Jul-2010
Time (UTC)09:02
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,114
Date (UTC)19-Jul-2010
Time (UTC)13:08
PlatformNot applicable

↑ Back to the top


Keywords: kb, kbmdd, kbbug, kbautohotfix, kbfix, kbhotfixserver, kbexpertiseinter

↑ Back to the top

Article Info
Article ID : 2028815
Revision : 1
Created on : 1/7/2017
Published on : 10/9/2014
Exists online : False
Views : 364