Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The multicast packets are not fragmented by using the specified MTU value that is set in the registry in Windows Server 2003 SP2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You set an Ethernet Maximum Transmission Unit (MTU) value for a network adapter on a computer that is running Windows Server 2003 Service Pack 2 (SP2).
  • You transfer Pragmatic General Multicast (PGM) multicast packets by using the network adapter.
In this scenario, these PGM multicast packets are not fragmented by using the Ethernet MTU value that you set. Instead, the default MTU value of 1500 is used.

↑ Back to the top


Cause

This issue occurs because the Rmcast.sys driver that handles the multicast packets does not fragment the packets by using the specified MTU value in the related registry key.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 Service Pack 2 (SP2).

For more information about how to obtain a Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Registry information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756� How to back up and restore the registry in Windows
After you install this hotfix, you must set the MTU value of the multicast packets. To do this, create the following registry item manually:
Location: HEKY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RMCAST

Name: PgmMTU

Type: REG_DWORD

Value: <The MTU value>

Note<The MTU value> is a placeholder for the MTU value for the network adapter.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Rmcast.sys5.2.3790.4708110,08012-May-201014:03x86
For all supported x64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Rmcast.sys5.2.3790.4708181,76012-May-201013:37x64
For all supported IA-64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Rmcast.sys5.2.3790.4708341,50412-May-201013:37IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, KB2028773

↑ Back to the top

Article Info
Article ID : 2028773
Revision : 1
Created on : 6/28/2010
Published on : 6/28/2010
Exists online : False
Views : 256