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Event ID 783 is logged unexpectedly in the Application log when you manually start a Microsoft Component Services (COM+) application in Windows Vista or Windows Server 2008


View products that this article applies to.

Symptoms

When you manually start a Microsoft Component Services (COM+) application that uses object pooling on a computer that is running Windows Vista or Windows Server 2008, the following event is logged in the Application log:

Log Name: Application
Source: Microsoft-Windows-Complus
Date: <Date Time>
Event ID: 783
Task Category: Process Dump
Level: Information
Keywords: Classic
Description: The average call duration has exceeded 10 minutes. If this is not the expected behavior, please see article 910904 in the Microsoft Knowledge Base at http://support.microsoft.com for details on how to use the COM+ AutoDump feature to automatically generate dump files and/or terminate the process if the problem occurs again.
Server Application ID: {Application id}
Server Application Instance ID: {Application Instance id}
Server Application Name: Application name



Note If the COM+ application does not use object pooling, this event is logged only when the first call to the COM+ application is made from a remote client. This event is not logged for later calls to the COM+ application.

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Cause

This issue occurs because the hang detection timer of the operating system is set to -1 when you manually start a COM+ application that uses object pooling. This indicates that the data for hang detection is not available. However, "-1" is�interpreted incorrectly as a very high call time. Therefore, the event is logged unexpectedly in the Application log.

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Resolution

Hotfix information

�A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Vista Service Pack 2 (SP2) or Windows Server 2008 SP2. For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important�Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only Windows Vista is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under Windows Vista on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Catsrvut.dll2001.12.6932.22404489,47213-May-201018:22x86
Comsvcs.dll2001.12.6932.224041,210,88013-May-201018:22x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Catsrvut.dll2001.12.6932.22404532,48013-May-201018:21x64
Comsvcs.dll2001.12.6932.224041,687,55213-May-201018:21x64
Catsrvut.dll2001.12.6932.22404489,47213-May-201018:22x86
Comsvcs.dll2001.12.6932.224041,210,88013-May-201018:22x86
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Catsrvut.dll2001.12.6932.224041,220,09613-May-201018:07IA-64
Comsvcs.dll2001.12.6932.224043,227,64813-May-201018:07IA-64
Catsrvut.dll2001.12.6932.22404489,47213-May-201018:22x86
Comsvcs.dll2001.12.6932.224041,210,88013-May-201018:22x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

If you encounter the same issue in Windows Server 2003, apply the hotfix that is described in the Microsoft Knowledge Base article 949475. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
949475 FIX: An event may be logged when you manually start a COM+ application on a computer that is running Windows Server 2003 with Service Pack 2: "The average call duration has exceeded 10 minutes"
For more information about COM+ service,�go to the following website:� For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameUpdate.mum
File versionNot applicable
File size3,078
Date (UTC)14-May-2010
Time (UTC)02:34
PlatformNot applicable
File nameX86_2d435693d2cf8f7f903961d71cd193c9_31bf3856ad364e35_6.0.6002.22404_none_5539735c3ceaf8af.manifest
File versionNot applicable
File size728
Date (UTC)14-May-2010
Time (UTC)02:34
PlatformNot applicable
File nameX86_microsoft-windows-c..fe-catsrvut-comsvcs_31bf3856ad364e35_6.0.6002.22404_none_7536806cb61e4431.manifest
File versionNot applicable
File size240,534
Date (UTC)13-May-2010
Time (UTC)20:12
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_a43b67d96b0b641ed5b23bf19d4b0e9e_31bf3856ad364e35_6.0.6002.22404_none_494a6c576eabc19e.manifest
File versionNot applicable
File size1,104
Date (UTC)14-May-2010
Time (UTC)02:34
PlatformNot applicable
File nameAmd64_microsoft-windows-c..fe-catsrvut-comsvcs_31bf3856ad364e35_6.0.6002.22404_none_d1551bf06e7bb567.manifest
File versionNot applicable
File size240,633
Date (UTC)13-May-2010
Time (UTC)20:10
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size3,102
Date (UTC)14-May-2010
Time (UTC)02:34
PlatformNot applicable
File nameX86_microsoft-windows-c..fe-catsrvut-comsvcs_31bf3856ad364e35_6.0.6002.22404_none_7536806cb61e4431.manifest
File versionNot applicable
File size240,534
Date (UTC)13-May-2010
Time (UTC)20:12
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_05675f89a29ac0c65ecd537132376a95_31bf3856ad364e35_6.0.6002.22404_none_7c6720a40be80a49.manifest
File versionNot applicable
File size1,102
Date (UTC)14-May-2010
Time (UTC)02:34
PlatformNot applicable
File nameIa64_microsoft-windows-c..fe-catsrvut-comsvcs_31bf3856ad364e35_6.0.6002.22404_none_75382462b61c4d2d.manifest
File versionNot applicable
File size240,599
Date (UTC)13-May-2010
Time (UTC)19:41
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,255
Date (UTC)14-May-2010
Time (UTC)02:34
PlatformNot applicable
File nameX86_microsoft-windows-c..fe-catsrvut-comsvcs_31bf3856ad364e35_6.0.6002.22404_none_7536806cb61e4431.manifest
File versionNot applicable
File size240,534
Date (UTC)13-May-2010
Time (UTC)20:12
PlatformNot applicable

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Keywords: KB2028768, kbexpertiseinter, kbexpertiseadvanced, kbsurveynew, kbfix, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 2028768
Revision : 5
Created on : 7/12/2013
Published on : 7/12/2013
Exists online : False
Views : 579