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A shared file is truncated when you write data to the file by using a computer that is running Windows Server 2003 if the file is stored on a third-party SMB file server and if the file is larger than 4 GB


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You try to write data to a shared network file on a computer that is running Windows Server 2003. The file is larger than 4 gigabytes (GB).
  • A third-party Server Message Block (SMB))/ Common Internet File System (CIFS) file server hosts the shared network file.
In this scenario, the shared file is truncated after the write operation. Therefore, some data loss occurs.�

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Cause

This issue occurs because a SMB redirector query fails when the SMB redirector tries to extend the file size of the shared file.

When you write data to a shared network file, the SMB redirector tries to extend the file size. After the file is extended, the SMB redirector queries the allocation information. If this query fails, the file is truncated to the previous file size. However, the high part of the file size is ignored during the truncation process. Therefore, some data is lost.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 Service Pack 2 (SP2).

For more information about how to obtain a Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameMrxsmb.sys
File version5.2.3790.4711
File size439,296
Date (UTC)19-May-2010
Time (UTC)04:49
For all supported x64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameMrxsmb.sys
File version5.2.3790.4711
File size787,968
Date (UTC)19-May-2010
Time (UTC)06:02
For all supported IA-64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameMrxsmb.sys
File version5.2.3790.4711
File size1,173,504
Date (UTC)19-May-2010
Time (UTC)06:02

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, KB2028684

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Article Info
Article ID : 2028684
Revision : 2
Created on : 7/6/2010
Published on : 7/6/2010
Exists online : False
Views : 222