Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Action center in Windows 7 reporting that antivirus is not installed


Symptoms

The Action Center in Windows 7 shows that antivirus, antispyware or firewall is not installed when they are in fact installed and working normally.

↑ Back to the top


Cause

Due to a change to the Security Center interface for ISVs, some antivirus, antispyware, and firewall programs could be incompatible with the Action Center in Windows 7.

New APIs were introduced in Vista SP1 that implemented new API's. More information on this case be found at the following link:

Upcoming Action Center Changes for Security Vendor Software
http://windowsteamblog.com/blogs/windowssecurity/archive/2009/05/06/upcoming-action-center-changes-for-security-vendor-software.aspx

If the application vendor does not use the appropriate API's, the Action Center will not show that the product is properly installed.

↑ Back to the top


Resolution

Please contact the antivirus\antispyware\firewall vendor for a newer version of their software.

↑ Back to the top


Keywords: vkball, kb

↑ Back to the top

Article Info
Article ID : 2028210
Revision : 1
Created on : 1/8/2017
Published on : 11/11/2011
Exists online : False
Views : 127