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You cannot save a Performance Monitor log file on a mapped drive in Windows Server 2008 or in Windows Server 2003


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Symptoms

Consider the following scenario. You configure a Performance Monitor log file by using performance monitoring tool. The location of this log file refers to a network mapped drive. In this scenario, you may receive the following error message:

The <Log Setting Name> log or alert has not started. Refresh the log or alert list to view current status, or see the application event log for any errors.
Some logs and alerts might require a few minutes to start, especially if they include many counters or they contain counters to be collected from a remote system that is no longer on the network.
For further information see the troubleshooting section in the online help.

Additionally, the following event�ID is logged in the Application log:

Event Type:�Warning
Event Source:�SysmonLog
Event Category:�None
Event ID:�2036
Date:��4/16/2010
Time:��11:46:03 AM
User:��N/A
Computer:�2K3-TS2
Description: Unable to create the Z:\t folder for the test log configuration. This log will not be started. The error returned is: The system cannot find the path specified.

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Cause

This issue occurs because services are not designed to interact with mapped drives across user sessions. For more information about this functionality, see the following Microsoft Knowledge Base article:

INFO: Services and Redirected Drives

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Resolution

To work around this issue, set an administrator account to run Performance Monitor.�Or, set the Performance Logs and Alerts service to run on an administrator account.

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More information

When the system establishes a redirected drive, it is stored on a per-user basis.Only the user can manipulate the redirected drive. The system keeps track of redirected drives based on the user's logon security identifier (SID). The logon SID is a unique identifier for the user's logon session. A single user can have multiple logon sessions on the system at the same time.�

If a service is configured to run under a user account, the system will always create a new logon session for the user and then start the service in that new logon session. Therefore, the service cannot manipulate the drive mappings that are established in the user's other session or sessions.�

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Keywords: KB2027620

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Article Info
Article ID : 2027620
Revision : 1
Created on : 5/25/2010
Published on : 5/25/2010
Exists online : False
Views : 282