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You receive a "File already in use" error message when you open a database on a server in Access 2000


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Symptoms

When you try to open a database that is located on a server, you may receive the following error message:
Couldn't use <filename>; file already in use.

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Cause

If a user opens a database and doesn't have create rights for the folder in which the database is located, the Microsoft Jet database engine can't create the locking information file (*.ldb) that is necessary for multiple users to open the database. Therefore, a user who doesn't have create rights opens the database exclusively if a corresponding .ldb file does not already exist.

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Resolution

To prevent this behavior, you must make sure that all users who open the database have read, write, and create rights for the folder in which the database is located.

If you are using a security-enhanced Access database, you must make sure that the users who open the database also have Read permission and Write permission on the folder that contains the workgroup information (.mdw) file.

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More information

In order to open a database in shared mode, the Microsoft Jet database engine must be able to create a locking information file (*.ldb) in the same folder as the database itself.

For additional information about .ldb files, click the following article number to view the article in the Microsoft Knowledge Base:
208778 Introduction to .ldb files in Access 2000

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For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
210178 Contents of the Readme file for Access 2000

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Keywords: KB202171, kb3rdparty, kbprb, kberrmsg

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Article Info
Article ID : 202171
Revision : 2
Created on : 7/28/2004
Published on : 7/28/2004
Exists online : False
Views : 384