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ConfigMgr 2007: A Windows OS installation may fail to in an Configuration Manager 2007 OSD Task Sequence if a Product Key is not correctly specified


Symptoms

When deploying a Windows OS from installation source files (Operating System Install Package) via an Configuration Manager 2007 OSD Task Sequence, if the Windows version has multiple editions/versions as part of the installation source files (Windows Vista, Windows Server 2008, Windows 7, or newer), the following error message may be displayed when the PC is rebooted from the WinPE stage:

Boot mgr is missing

Examining the contents of the hard drive reveals that no Windows OS has been installed on the hard drive and that the only contents on the hard drive are aC:\SMSTSLog folder. Examining the SMSTS.log in this folder reveals the following error message:


Set command line: "C:\_SMSTaskSequence\Packages\<Package_ID>\SOURCES\SETUP.EXE" "/unattend:C:\_SMSTaskSequence\unattend.xml" /noreboot OSDSetupWindows
Executing command line: "C:\_SMSTaskSequence\Packages\<Package_ID>\SOURCES\SETUP.EXE" "/unattend:C:\_SMSTaskSequence\unattend.xml" /noreboot OSDSetupWindows
Process completed with exit code 31 OSDSetupWindows
Windows Setup completed with exit code 31 OSDSetupWindows
Entering ReleaseSource() for C:\_SMSTaskSequence\Packages\<Package_ID> OSDSetupWindows
reference count 1 for the source C:\_SMSTaskSequence\Packages\<Package_ID> before releasing OSDSetupWindows
Delete source directory C:\_SMSTaskSequence\Packages\<Package_ID> OSDSetupWindows
Released the resolved source C:\_SMSTaskSequence\Packages\<Package_ID> OSDSetupWindows
exitCode == 0, HRESULT=80004005 (e:\nts_sms_fre\sms\client\osdeployment\setupwindows\setupwindows.cpp,440) OSDSetupWindows
Windows setup failed, code 31 OSDSetupWindows
setup.run(), HRESULT=80004005 (e:\nts_sms_fre\sms\client\osdeployment\setupwindows\setupwindows.cpp,1707) OSDSetupWindows
Exiting with code 0x80004005 OSDSetupWindows
Process completed with exit code 2147500037 TSManager
!--------------------------------------------------------------------------------------------! TSManager
Failed to run the action: Setup Windows and ConfigMgr.
Unspecified error (Error: 80004005; Source: Windows) TSManager


Taking a look at the setuperr.log and setupact.log from the C:\SMSTSLog folder reveals the following error message:

setuperr.log
<Date> <Time>, Error      [0x0603ef] IBS    CallBack_SelectImageOrShowUi: There are no matching OS images
<Date> <Time>, Error      [0x06066d] IBS    CallBack_SelectImageOrShowUi: Couldn't decide which Windows image to use and was asked to never show the UI in unattend mode. hr =0x80004005


setupact.log
<Date> <Time>, Error      [0x0603ef] IBS    CallBack_SelectImageOrShowUi: There are no matching OS images
<Date> <Time>, Error      [0x06066d] IBS    CallBack_SelectImageOrShowUi: Couldn't decide which Windows image to use and was asked to never show the UI in unattend mode. hr =0x80004005
<Date> <Time>, Info       [0x0640ae] IBSLIB PublishMessage: Publishing message [The product key entered does not match any of the Windows images available for installation. Enter a different product key.]

<Date> <Time>, Info       [0x0601d7] IBS    InstallWindows:Error Type = 3211266

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Cause

This problem can be caused if the Product ID for Windows edition specified in the "Apply Windows Settings" task, in the unattend.xml file, or in theOSDProductKey variable does not match the Windows edition specified in the "Apply Operating System" task. For example, the Product key being specified is for the Windows 7 Ultimate edition, but the edition being installed is Windows 7 Starter.

The problem can also happen if the Product key is either incorrect or mistyped.

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Resolution

The problem can be resolved in one of the following three ways. For Volume License versions of Windows, only option 3 should be taken.

  1. In the affected Task Sequence, make sure that the Product Key in the "Apply Windows Settings" task is for the edition of Windows specified in the "Apply Operating System" task.

  2. In the affected Task Sequence, make sure that the edition of Windows specified in the "Apply Operating System" task matches the edition of Windows that the Product Key in the "Apply Windows Settings" task is for.

  3. In the affected Task Sequence, remove the Product Key from the "Apply Windows Settings" task.

For non Volume License versions of Windows, the Product Key will still be prompted for during Windows Setup during the Task Sequence, but it does not have to be entered and you can click to continue past the screen where the Product Key is being prompted for. However the Product Key will need to be entered within 30 days for Windows to properly activate.

For Volume License versions of Windows, the Product Key should NEVER be entered into the "Apply Windows Settings" task as the Product Key and Windows Activation will be supplied by and performed by the KMS Activation Server.

For all of the above options, if the Product Key is being specified via the unattend.xml file or theOSDProductKey variable, then please make the appropriate changes to either the unattend.xml file or theOSDProductKey variable instead.

For the unattend.xml file, the Product Key is stored under the section:

<ProductKey>
           <Key></Key>
</ProductKey>

For options 1 and 2, simply edit the unattend.xml file in Notepad and update the Product Key in this section and then save the unattend.xml file.

For option 3, delete the above lines and save the unattend.xml file. The "Apply Windows Settings" task will automatically regenerate the section with the proper product key and add it into the unattend.xml file.

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More Information

For resolution on a similar issue with similar error messages, please see Bemis Article ID 2009813:

ConfigMgr 2007 - Error message "Failed to deserialize settings (0x00221006)" when deploying a Windows OS as an Operating System Install Package via an Configuration Manager 2007 OSD Task Sequence
http://bemis/15/Pages/2009813_en-US.aspx

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Keywords: vkball, kb

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Article Info
Article ID : 2009946
Revision : 1
Created on : 1/8/2017
Published on : 7/8/2010
Exists online : False
Views : 118