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ConfigMgr 2007: The Install Software Update task in an Configuration Manager 2007 OSD Task Sequence fails after exactly 30 minutes


Symptoms

In an Configuration Manager 2007 OSD Task Sequence that contains an Install Software Updates task, if a large amount of software updates need to be installed, the Task Sequence will fail after exactly 30 minutes after the software updates began to be installed. Checking the SMSTS.log shows the following errors:


Successfully initiated RefreshUpdates operation  11/24/2009 12:11:34 PM InstallSWUpdate
Waiting for RefreshUpdates complete notification from Updates Deployment Agent 11/24/2009 12:11:35 PM InstallSWUpdate
FALSE, HRESULT=800705b4 (e:\nts_sms_fre\sms\client\osdeployment\installswupdate\installswupdate.cpp,1351) 11/24/2009 12:41:35 PM InstallSWUpdate
Timedout waiting for updates refresh complete notification 11/24/2009 12:41:35 PM InstallSWUpdate
WaitForRefreshUpdatesComplete(spInstall), HRESULT=800705b4 (e:\nts_sms_fre\sms\client\osdeployment\installswupdate\installswupdate.cpp,1410) 11/24/2009 12:41:35 PM InstallSWUpdate
RefreshUpdates(), HRESULT=800705b4 (e:\nts_sms_fre\sms\client\osdeployment\installswupdate\installswupdate.cpp,998) 11/24/2009 12:41:35 PM InstallSWUpdate
InstallUpdates(pInstallUpdate, tType, sJobID, ulCookie), HRESULT=800705b4 (e:\nts_sms_fre\sms\client\osdeployment\installswupdate\main.cpp,279) 11/24/2009 12:41:35 PM InstallSWUpdate
Setting TSEnv variable SMSTSInstallUpdateJobGUID= 11/24/2009 12:41:35 PM InstallSWUpdate
Process(pInstallUpdate, tType), HRESULT=800705b4 (e:\nts_sms_fre\sms\client\osdeployment\installswupdate\main.cpp,349) 11/24/2009 12:41:35 PM InstallSWUpdate
Process completed with exit code 2147943860 11/24/2009 12:41:36 PM TSManager
!--------------------------------------------------------------------------------------------! 11/24/2009 12:41:36 PM TSManager
Failed to run the action: Install Software Updates.
This operation returned because the timeout period expired. (Error: 800705B4; Source: Windows) 11/24/2009 12:41:36 PM TSManager

The execution of the group (Build the Reference Machine) has failed and the execution has been aborted. An action failed.
Operation aborted (Error: 80004004; Source: Windows) 11/24/2009 12:41:37 PM TSManager
Failed to run the last action: Install Software Updates. Execution of task sequence failed.
This operation returned because the timeout period expired. (Error: 800705B4; Source: Windows) 11/24/2009 12:41:37 PM TSManager


Note that the time that the error occurred (Timedout waiting for updates refresh complete notification) occurred exactly 30 minutes after the previous log entry.

Reviewing the rest of the logs involved with Software Updates (WindowsUpdate.log, CAS.log, CIAgent.log, LocationServices.log, ScanAgent.log, SDMAgent.log, UpdatesDeployment.log, UpdatesHandler.log, UpdatesStore.log, WUAHandler.log) shows no error messages and indicate that the installation of the software updates were being performed as expected without any issues. However, after the error occurs in the SMSTS.log, some of the logs will indicate that they have cancelled any software updates that they had been scheduled to run:


UpdatesStore.log
Purging update status reported by update source {<GUID>}. 11/24/2009 12:45:15 PM UpdatesStore
Successfully raised state message for update (<GUID>) with state (NotApplicable). 11/24/2009 12:45:15 PM UpdatesStore

UpdatesDeployment.log
Request received - Resume 11/24/2009 12:45:10 PM UpdatesDeploymentAgent
No pending install assignment 11/24/2009 12:45:10 PM UpdatesDeploymentAgent
No other installations in pipeline. No reboot required. 11/24/2009 12:45:10 PM UpdatesDeploymentAgent
Update assignment delete event received. 11/24/2009 12:45:15 PM UpdatesDeploymentAgent
OnPolicyDelete for assignment ({<GUID>})...  11/24/2009 12:45:15 PM UpdatesDeploymentAgent
Cancelling active CI Agent job - {<GUID>} for assignment ({<GUID>}) 11/24/2009 12:45:15 PM UpdatesDeploymentAgent
Updates client config deletion event received. 11/24/2009 12:45:15 PM UpdatesDeploymentAgent
Disabling software Updates feature 11/24/2009 12:45:15 PM UpdatesDeploymentAgent

WUAHandler.log
Removed Update Source ({<GUID>}) of content type: 2 11/24/2009 12:45:21 PM WUAHandler

Note that the above entries in the above logs all occurred after the error occurred in the SMSTS.log.

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Cause

The issue happens because the Install Software Updates task is hard coded to a 30 minute time out. If the software updates are not complete within 30 minutes, the task will fail. The 30 minute time out is present to prevent the task from "hanging" and never completing in case a problem occurs during the Install Software Updates task (similar to the "Maximum allowed run time (minutes)" option found in the programs of Software Distribution packages). However, if there are many software updates to install, such as an instance where a reference OS image is being built, the 30 minute time limit may not be enough time to complete all of the software updates and may cause the Install Software Updates task to fail.

This problem is usually seen in older Windows operating systems and service packs where may software updates are applicable.

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Resolution

To resolve the problem, additional "Apply Software Updates" tasks need to be added to the Task Sequence to give additional time for the remaining updates to install:

  1. In the ConfigMgr 2007 console, navigate to "Computer Management" --> "Operating System Deployment" --> "Task Sequences".

  2. Rick click on the affected Task Sequence and choose "Edit"

  3. Select the "Install Software Updates" task.

  4. Click on the “Options” tab and then click on the option "Continue on error". This will allow the Task Sequence to continue even if the first "Install Software Updates" task times out and fails.

  5. Immediately after the "Install Software Updates" task from Step 2, add a "Restart Computer" task and set the option "Specify what to run after restart" to "The currently installed default operating system". Uncheck the option "Notify the user before restarting". This step is necessary to make sure that the updates installed as part of the first "Install Software Updates" task are fully installed and not seen as still applicable when it scans a second time.

  6. Immediately after the "Restart Computer" task added in Step 5, add another "Install Software Updates" task. This should kick off a second software updates and continue where it left off. It will scan again but since some updates will have already have been installed, there should be less updates applicable.

The above instructions (Steps 3 -6) can be repeated to add a third or more Install Software Updates task as needed. Each instance of the Install Software Updates task will give an additional 30 minutes to install additional software updates. In most cases, only two Install Software Updates tasks should be enough to install all required software updates.

Note: The above resolution is intended to fix issues where the timeout is caused by too many software updates to be installed and the 30 minute time limit is not enough time to get them all installed. It is NOT intended to fix issues where the Software Update deployment hangs for other reasons (although it may also fix some of these issues too).

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Keywords: vkball, kb

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Article Info
Article ID : 2009754
Revision : 1
Created on : 1/8/2017
Published on : 9/13/2010
Exists online : False
Views : 187