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Error message when you undo a receipt with item tracked items in Microsoft Dynamics NAV: "You do not have permission to delete from the Whse. Item Entry Relation table"


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Symptoms

When you undo a receipt in Microsoft Dynamics NAV you receive the following error message:

You do not have permission to delete from the Whse. Entry Relation table.

This problem may occur if the following conditions are true:

1. The item is item tracked.

2. Receive is set to true on the location card. 

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Cause

This error occurs because the Whse. Undo Quantity codeunit (7320) is missing permissions for the Whse. Item Entry Relation table (6509).

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Resolution

To resolve this problem, change the code in the Whse. Undo Quantity codeunit (7320) as follows:

1. On the Tools menu, click Object Designer.
2. Click Codeunit and select the Whse. Undo Quantity codeunit (7320) and then click Design.
3. On the View menu, click Properties.
4. Click the AssistEdit button in the Permissions property
5. Select Whse. Item Entry Relation table (6509) and select Modify and Delete permissions and then click OK.
6. Save changes to the codeunit.

Note: Before you install this hotfix, verify that all Microsoft Dynamics NAV client users are logged off the system. This includes Microsoft Dynamics NAV Application Server (NAS) client users. You should be the only client user who is logged on when you implement this hotfix.

To implement this code change, you must have a developer license.

Microsoft provides programming examples for illustration only, without warranty either expressed or implied. This includes, but is not limited to, the implied warranties of merchantability or fitness for a particular purpose. This article assumes that you are familiar with the programming language that is being demonstrated and with the tools that are used to create and to debug procedures. Microsoft support engineers can help explain the functionality of a particular procedure, but they will not modify these examples to provide added functionality or construct procedures to meet your specific requirements.

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More Information

This problem exist in the following versions of Microsoft Dynamics NAV:

  • Microsoft Dynamics NAV 2009 SP1
  • Microsoft Dynamics NAV 2009
  • Microsoft Dynamics NAV 5.0 SP1
  • Microsoft Dynamics NAV 5.0

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Article Info
Article ID : 2009353
Revision : 2
Created on : 1/27/2017
Published on : 1/27/2017
Exists online : False
Views : 334