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Error message When You Bring up the Server Manager Console and click on Add / View Roles: "0x800B0100"


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Symptoms

When you bring up the Server Manager Console and click on Add / View Roles, it will populate the related information and will error out

ERROR:

"No signature 0x800B0100 ".

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Cause

 

This problem may occur when the component store that contains information about Vista or Windows 7 components is corrupted.

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Resolution

 

Follow the steps below to resolve the issue described above:

Step1:  Run the System Update Readiness Tool (CheckSur) and review the list of Manifest which are showing as missing.

After you run the tool, the Checksur.log file is saved in the following location:

%systemroot%\Logs\CBS
 
Open the Checksur.log in the notepad, you will find the errors like the files were missing. Record the complete file name for every missing file.
 
For example, in a log with errors, it will show you the file Package_for_KB948609~31bf3856ad364e35~amd64~~6.0.6001.3053.mum was missing. 
 
Checking System Update Readiness.
Version 6.0.6001.22275
2009-07-20 22:35

Checking Deployment Packages

Checking Package Manifests and catalogs.

Checking package watchlist.

Checking component watchlist.

Checking packages.
(f) CBS MUM Missing 0x00000002 
Package_for_KB948609~31bf3856ad364e35~amd64~~6.0.6001.3053.mum
 
Checking component store

Checking SMI Store
Summary:
Milliseconds: 163995
Found 1 errors
CBS MUM Missing Total Count: 1

To download System Update Readiness Tool (CheckSur), review the information found in the following article:

947821 Description of the System Update Readiness Tool for Windows Vista, for Windows Server 2008, for Windows 7, and for Windows Server 2008 R2
http://support.microsoft.com/default.aspx?scid=kb;EN-US;947821


 

Step2:  Copy the missing manifest (For example Package_for_KB948609~31bf3856ad364e35~amd64~~6.0.6001.3053.mum) from another working machine into the same folder path on the problem machine.

NOTE: Care should be taken when copying packages from other systems to ensure that the exact package noted in the CheckSUR.log output is the file being copied.  Many manifests in the package directory will contain localized versions of the component that needs to be fixed.  Copying the localized version of the manifest will not result in a resolution to this issue.  Localized versions of manifests will take the following format (the localized bit is in bold in the example below):

Package_for_KB948609~31bf3856ad364e35~amd64~en-US~6.0.6001.3053.mum

In addition to localization, system architecture must also be matched when copying a missing manifest.  x86 and x64 manifests are not cross architecture compatible.

NOTE: Only Trusted Installer has Full Permissions on c:\windows\servicing\packages directory.

You will need to take ownership of this folder using the following steps to be able to add any files:

  1. Right-click on the folder and choose Properties,
  2. Click Security tab.
  3. Click Advanced button.
  4. Click Owner tab.
  5. Click Edit button.
  6. Select your account.

After you have Full Permissions you should be able to copy files to this folder.

Step3: Verify the problem has been resolved by opening Server Manager Console and repeating the previous operation.

Step4: Once verified, you must restore the original permissions such that "Trusted Installer" has Ownership:

  1. Right-click on the folder and choose Properties,
  2. Click Security tab.
  3. Click Advanced button.
  4. Click Owner tab.
  5. Click Edit button.
  6. Click Other User or Group and type in: NT SERVICE\TrustedInstaller

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More information

CheckSur tool can be downloaded at http://support.microsoft.com/kb/947821

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Keywords: KB2006291

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Article Info
Article ID : 2006291
Revision : 3
Created on : 9/7/2010
Published on : 9/7/2010
Exists online : False
Views : 195