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The Outlook auto-complete feature makes incorrect suggestions


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Symptoms

When you enter the name of a recipient in the To box of an email message in Microsoft Outlook, the auto-complete feature suggests a recipient. However, either the suggestion is incorrect or the recipient is no longer with your organization.

Note When you send the email message to the person whom the auto-complete feature helped you find, you receive a non-delivery report (NDR) that states that the recipient does not exist. The NDR is accompanied by a 5.1.1 status code.

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Cause

This issue occurs because the Outlook auto-complete file contains obsolete or invalid entries.

Auto-complete is a feature in Outlook that caches email address information for frequently used contacts. Sometimes incorrect information is cached. When this occurs, the incorrect information should be removed.

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Resolution

The auto-complete feature uses a file on the computer to store frequently used contacts. If you access your mailbox by using multiple computers, the auto-complete entries will vary from computer to computer. 

Entries can be removed from your auto-complete file individually, or you can delete the whole file. If you delete the file, Outlook creates a new file.

To remove a specific auto-complete entry, follow these steps:

  1. Start a new email message in Outlook.
  2. Start to type the contact’s name until Outlook suggests prepopulated contacts.
  3. Use the Up and Down arrow keys to select the appropriate entry.
  4. Press the Delete key.
  5. Type the contact’s name or email address, and then press Ctrl+K.
  6. If the contact is an internal user, double-click the entry to make sure that it resolves correctly by using the global address list. If the contact is an external user, send that contact a test email message and confirm that it was received successfully.


To delete the auto-complete file, follow these steps.

Note These steps should be used only if there’s a problem with many of the entries in your auto-complete file. 

  1. Close Outlook.
  2. Click Start, select Run, type %userprofile%, and then click OK.
  3. Configure Windows Explorer to show hidden folders, To do this, follow these steps:
    a. In Windows Vista or Windows 7, press and hold the Alt key to display the menus.
    b. On the Tools menu, click Folder Options.
    c. Click the View tab.
    d. Make sure that Show hidden files, folders and drives is selected.
    e. Make sure that Hide extensions for known file types is not selected.
    f. Click OK.
  4. In Windows Vista or in Windows 7, open Appdata, Roaming, Microsoft, and then Outlook. In Windows XP, open Application Data, Microsoft, and then Outlook.
  5. Sort by the Date Modified column to show the most recent items at the top.
  6. Identify the most recently changed auto-complete file. The file name extension of an auto-complete file is ".nk2," and the file name has the name of the Outlook profile. If it is not clear which Outlook profile name is the most current , follow these steps:
              a. In Control Panel, click the Mail icon (in Windows XP) or User Accounts - Mail (in Windows Vista or Windows 7). 
              b. Click Show Profiles. The default profile will be listed under Always use this profile.          
  7. Right-click the file, and then add .old to the end of the file name.

    The next time that Outlook is started, a new auto-complete file will be generated.
The legacyExchangeDN attribute is stored in the user's auto-complete file. If this attribute is changed for any reason, contacts that send email message to the user will have the email returned together with a 5.1.1 NDR. Although the steps that are provided in this article resolve the issue, this procedure has to be performed by each user individually. To avoid this ongoing problem, an x500 address can be added to the user's EmailAddresses (proxyAddresses) attribute. To do this, follow these steps:
  1. Review the NDR to analyze the address to which the users are trying to send email messages. The address will be similar in format to the following:
  2. IMCEAEX-_O=MMS_OU=EXCHANGE+20ADMINISTRATIVE+20GROUP+20+28FYDIBOHF23SPDLT+29_CN=RECIPIENTS_CN=user1@company.com

    Note This format indicates that the legacyExchangeDN attribute is translated by Exchange to an SMTP address.   

  3. Translate the address to legacyExchangeDN format. To do this, follow these steps:
              a. Remove IMCEAEX-. 
              b. Replace any underscore (_) with a forward slash (/).
              c. Replace +20 with a blank space.
              d. Replace +28 with an opening parenthesis.
              e. Replace +29 with a closing parenthesis.
  4. For example, the address in step 1 would become the following:

    /O=MMS/OU=EXCHANGE ADMINISTRATIVE GROUP (FYDIBOHF23SPDLT)/CN=RECIPIENTS_CN=user1@company.com

  5. Review the user's legacyExchangeDN attribute. If it does not match the legacyExchangeDN attribute that is in the user's auto-complete file, add legacyExchangeDN as an x500 address on the user's object by using the Active Directory Service Interfaces (ADSI) Edit tool or the Ldp GUI tool. Do not change the legacyExchangeDN attribute unless you are directed to do this by Office 365 Support.

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More information

 

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Keywords: KB2005644, KB2005644

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Article Info
Article ID : 2005644
Revision : 12
Created on : 9/3/2013
Published on : 9/3/2013
Exists online : False
Views : 412