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After upgrading a printer driver on any Microsoft Operating system later than Windows XP and Server 2003, the old driver files are still being used.


View products that this article applies to.

Symptoms

Consider the following scenario:

You have a printer driver installed on the system. You attempt to install a newer version of the driver.  Both the new driver and the old driver have the same name (i.e. "ABC Model 1000"). After you install the driver, the old driver's files may still be used when printing, or the driver may no longer function correctly because registry entries for the driver are inconsistent.

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Cause

Microsoft has confirmed this as an issue, and it can be worked around by following the instructions in the Resolution section.

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Resolution

Perform the following workaround:

1.  In the Printers folder, find the existing printers on the system that are using the old driver.

2.  Delete the printers or reconfigure the printers using the old driver to use a different driver via the "Printer Properties" - "Advanced" tab.

3.  Go to "Print Server Properties" - "Drivers" tab.

4.  Delete the old driver.

5.  Install the new driver using the "Add Driver" wizard.

6.  Recreate the printers or reconfigure the existing printers to use the new driver.

Regarding Vista and Windows 7 clients connecting to a print server, the clients will need to delete the network printer, uninstall the printer driver, and then reconnect to the shared printer.  This will involve having Administrator level rights to delete the driver.  IT administrators can automate the process using the Printui.dll scripting options.  Run "rundll32 printui.dll,PrintUIEntry /?" for available switches to delete printers and printer drivers.

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Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

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Keywords: KB2004234

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Article Info
Article ID : 2004234
Revision : 1
Created on : 11/10/2009
Published on : 11/10/2009
Exists online : False
Views : 305