Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

ACC2000: How to Open a Data Access Page in the Script Editor


View products that this article applies to.

This article was previously published under Q198451
Moderate: Requires basic macro, coding, and interoperability skills.

↑ Back to the top


Summary

Microsoft Access includes a tool called the Microsoft Script Editor that you can use to edit the script behind data access pages. There are four ways to open the Script Editor from Design view of a data access page.

↑ Back to the top


More information

To open the Script Editor from Design view of a data access page, use one of the following methods.

Method 1

Right-click an empty portion of the data access page, and then on the shortcut menu, click Microsoft Script Editor.

Method 2

On the Tools menu, point to Macro, and then click Microsoft Script Editor.

Method 3

Press ALT+SHIFT+F11.

Method 4

On the View menu, click HTML Source.

When you open the Script Editor by using methods 1 through 3, you enable the following features. You also enable these features when you open the Script Editor with method 4, provided that there is already an instance of the Script Editor open, and you opened that instance by using one of the other methods.

Enabled Features

HTML (Document) Outline window
Script Outline window
The page has a Design tab (not used with Microsoft Office documents)
The page has a Quick View tab
When you view the Source tab, items in the following windows are available:
HTML (Document) Outline
Toolbox
Script Outline
Properties
The Script Editor also enables the following menus, submenus, and menu commands:
              Menu                         Submenu
   Menu       Item                         Item
   ---------------------------------------------------------

   Edit       Paste As HTML
   Edit       List Members
   Edit       Parameter Info
   Edit       Complete Word

   View       Sync Script Outline
   View       View Controls As Text
   View       View Control Graphically      
   View       Properties Window
   View       Toolbox
   View       Debug Windows                Immediate
   View       Debug Windows                Autos
   View       Debug Windows                Locals
   View       Debug Windows                Watch
   View       Debug Windows                Threads
   View       Debug Windows                Call Stack
   View       Debug Windows                Running Documents
   View       Other Windows                Document Outline
   View       Other Windows                Output
   View       Other Windows                Script Outline
   View       Define Window Layout
   View       Property Pages

   Debug      Start
   Debug      Start Without Debugging
   Debug      Break
   Debug      End
   Debug      Detach All Processes
   Debug      Restart
   Debug      Run To Cursor
   Debug      Step Into
   Debug      Step Over
   Debug      Step Out
   Debug      Add Watch
   Debug      Insert Breakpoint
   Debug      Enable Breakpoint
   Debug      Clear All Breakpoints
   Debug      Breakpoints
   Debug      Set Next Statement
   Debug      Show Next Statement
   Debug      Processes

   HTML       Link
   HTML       Bookmark
   HTML       Image
   HTML       Form
   HTML       Div
   HTML       Span
   HTML       Marquee
   HTML       Script Block                 Client
   HTML       Script Block                 Server
   HTML       HTML Wizards

   Table      Insert Table
   Table      Insert Row
   Table      Delete Row
   Table      Insert Column
   Table      Delete Column
   Table      Insert Cell
   Table      Delete Cell
   Table      Merge Cells
   Table      Split Cell

   Format     Bold
   Format     Italic
   Format     Underline
   Format     Superscript
   Format     Subscript
   Format     Decrease Indent
   Format     Increase Indent
   Format     Absolute Positioning
   Format     Lock
   Format     Z Order                      Bring to Front
   Format     Z Order                      Send to Back
   Format     Z Order                      Bring Forward
   Format     Z Order                      Send Backward
   Format     Z Order                      Behind Text
   Format     Z Order                      Front of Text

   Tools      Customize Toolbox
				

↑ Back to the top


Keywords: KB198451, kbdap, kbhowto

↑ Back to the top

Article Info
Article ID : 198451
Revision : 1
Created on : 6/28/2004
Published on : 6/28/2004
Exists online : False
Views : 365