Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive an "Extension 'SMTP' could not be loaded" error message in Exchange Server 5.0 and in Exchange Server 5.5


View products that this article applies to.

This article was previously published under Q196924

↑ Back to the top


Symptoms

When you try to open the properties of the Internet Mail Service, the following error message may be displayed:
Extension 'SMTP' could not be loaded.
ID no: 0c103ad1.

↑ Back to the top


Cause

The Imcadmin.dll file is causing a version conflict. To correct the problem, you need to find the build number of the file (file properties, or the Filever utility), and use that number to make a raw mode entry change.

↑ Back to the top


Workaround

Perform the following steps at the computer that is running the Exchange Server Administrator program to find the build number of the file:
  1. Map a drive to the Exchsrvr folder of the computer on which the Internet Mail Service is installed.
  2. In Windows NT Explorer, locate the Imcadmin.dll file in the following folder:
    Exchsrvr\Addins\Smtp\I386
  3. Click the Imcadmin.dll file, and on the File menu, click Properties.
  4. Click the Version tab, and write down the file version that is displayed here.
Perform the following steps at the computer that is running the Exchange Server Administrator program to use the version number to make a raw mode entry change:

Warning If you use the raw mode of the Exchange Server Administrator program (admin /r) incorrectly, serious problems may occur that may require you to reinstall Microsoft Windows NT Server, Microsoft Exchange Server, or both. Microsoft cannot guarantee that problems that result from using raw mode incorrectly can be solved. Use raw mode at your own risk.

  1. Start the Exchange Server Administrator in raw mode by typing the following at a command prompt:
    c:\exchsrvr\bin\admin.exe /r
  2. In the Exchange Server Administrator program connected to the Internet Mail Service computer, click to expand the Configuration container, and then click Add-ins.
  3. In the right pane of the window, click Extension for Internet Mail Service I386.
  4. On the File menu, click Raw Properties.
  5. In the Attribute list, click File Version, and then click Editor.
  6. Click File Version, and then click OK.
  7. Change the build number to the build number that you found in Windows NT Explorer, and then click OK.
  8. In the window Extension for Internet Mail Service I386, click Set.

↑ Back to the top


Keywords: KB196924, kbprb

↑ Back to the top

Article Info
Article ID : 196924
Revision : 6
Created on : 10/28/2006
Published on : 10/28/2006
Exists online : False
Views : 258