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XADM: Euro Displayed Incorrectly After MIME Conversion


View products that this article applies to.

This article was previously published under Q193256

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Symptoms

When you send a message with the Euro currency symbol (a "C" with two horizontal lines through the center) on the To, Cc, or Subject line, the symbol may be displayed as a question mark (?) when you open the message in an e-mail client, or when you view the message in the preview pane. This problem also occurs when you view the Subject line in the Inbox, on the taskbar, or on the title bar of the message window. However, Euro currency symbols in the body of the message are displayed properly.

Note that this problem only occurs when the following conditions are met:
The message's character set is Western European (ISO-8859-1).
The message is sent using Post Office Protocol version 3 (POP3) and received using Internet Mail Access Protocol (IMAP) or POP3.
In addition, note that this problem is not dependent on the e-mail client or operating system you are using. The problem can occur even if your e-mail client, the operating system on which the e-mail client is running, and the Microsoft Exchange Server computer all support the euro currency symbol.

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Cause

This problem occurs because the Western European character set does not support the Euro currency symbol. Therefore, the Euro currency symbol is not converted properly when the information store converts the message from Multipurpose Internet Mail Extensions (MIME) format so that it can be viewed in a Messaging Application Programming Interface (MAPI) or POP3 e-mail client.

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Resolution

Exchange Server 5.0

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Exchange Server version 5.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:

Component: Information Store

File nameVersion
Mdbmsg.dll5.0.1461.85
Store.exe5.0.1461.85

After you apply the fix, if you are sending a message from a POP3 e-mail client to a MAPI e-mail client, you must select the Allow 8-Bit Characters In Headers check box in the POP3 e-mail client. If you are sending a message from a POP3 e-mail client to another POP3 e-mail client, you do not need to select this check box, but the euro currency symbol is still displayed correctly if you do.

Exchange Server 5.5

To resolve this problem, obtain the latest service pack for Exchange Server version 5.5. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
191014 XGEN: How to Obtain the latest Exchange Server 5.5 Service Pack
The English version of this fix should have the following file attributes or later:


Component: Information Store

File nameVersion
Gapi32.dll5.5.2539.0
Mdbmsg.dll5.5.2539.0
Store.exe5.5.2539.0


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Status

Microsoft has confirmed that this is a problem in Microsoft Exchange Server versions 5.0 and 5.5. This problem was corrected in Exchange Server 5.5 Service Pack 3.

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More information

After you apply the fix, messages that are labeled with the ISO-8859-1 character set are labeled with the Windows-1252 character set instead. This allows the Euro currency symbol to be converted properly by the information store. However, if your e-mail client, the operating system on which the e-mail client is running, or the Microsoft Exchange Server computer do not support the Euro currency symbol, the symbol may still be displayed incorrectly when you view the To, Cc, or Subject line in an e-mail client.

For information about the availability of the euro currency symbol in Microsoft Windows NT character sets, please see the following article in the Microsoft Knowledge Base:
182005 Euro Currency Not Available in Windows NT Character Sets

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Keywords: kbexchange500presp3fix, kbbug, kbqfe, kbhotfixserver, kbfix, KB193256

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Article Info
Article ID : 193256
Revision : 9
Created on : 10/28/2006
Published on : 10/28/2006
Exists online : False
Views : 357