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Internet Explorer Was Unable to Import This Certificate


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Symptoms

When you attempt to import a digital certificate into Internet Explorer from another browser, you may receive the following error message:
Internet Explorer was unable to import this certificate.

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Cause

This error message can occur if you are attempting to import a 1024-bit key (high grade) or greater digital certificate, and you are not running the 128-bit version of Internet Explorer.

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Resolution

To resolve this behavior, upgrade to the 128-bit version of Internet Explorer. To obtain the 128-bit Internet Explorer Upgrade, please visit the following Microsoft Web site:

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More information

The 128-bit Internet Explorer Upgrade installs the Rivest-Shamir-Adleman (RSA) certificate provider. With the RSA certificate provider, you can import high grade digital certificates into Internet Explorer in PFX format.

You can import only 512-bit key (low grade) digital certificates into Internet Explorer.

Additional Information

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

Note that this behavior can also occur if a previously exported 1024-bit key (high-grade) is improperly imported into a different system.

When this occurs, the 128-bit Cryptographic Service Provider (CSP) is not registered as the default provider. When you try to import the 1024-bit certificate onto a 1024-bit system, it does not work because it is trying to make a call to the default 512-bit base (exportable) provider, which does not accept strong cryptographic key sizes (>512 bit).

To correct this problem, change the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\Defaults\Provider Types\Type 001

Name = "Microsoft Base Cryptographic Provider v1.0"

to

Name = "Microsoft Enhanced Cryptographic Provider v1.0"


This behavior can also occur if the user key for the certificate you are trying to import already exists in the following registry key:
HKEY_CURRENT_USER\Software\Microsoft\Cryptography\UserKeys
To work around this behavior, delete the appropriate user key in the above registry key.

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Properties

Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

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Keywords: kbenv, kberrmsg, kbprb, KB182054

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Article Info
Article ID : 182054
Revision : 6
Created on : 3/29/2007
Published on : 3/29/2007
Exists online : False
Views : 493