Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Not Prompted to Specify Download Folder for File


View products that this article applies to.

Symptoms

When you download a file from the Internet, you may not be prompted for the location in which to save the file that you are downloading. Instead, the file may be opened.

↑ Back to the top


Cause

This behavior can occur if you clear the Always ask before opening this type of file check box when you download a file. If you do this, files of this type are automatically placed in the Temporary Internet Files folder and opened by the program that is associated with the file type.

↑ Back to the top


Resolution

If you want to be prompted for a download location for the file type, follow these steps:
  1. Double-click My Computer.
  2. On the View menu, click Folder Options.
  3. On the File Types tab, click the appropriate file type in the Registered File Types box.
  4. Click Edit.
  5. Click to select the Confirm Open After Download check box.
  6. Click OK, and then click OK.

↑ Back to the top


More information

When you first click a link to download a file, the File Download dialog box appears. You have the following options:
  • Open this file from its current location
  • Save this file to disk
  • Always ask before opening this type of file
If you clear the Always ask before opening this type of file check box, you indicate that this type of file should always be opened with the associated program. The file is then downloaded to your Temporary Internet Files folder and opened.

If the Always ask before opening this type of file check box is unavailable, there is no program associated with the file type. For example, if you download a file with a .zip extension, the check box is unavailable unless you have installed a program that can open .zip files.

For additional information about downloading .exe files with Internet Explorer, click the article number below to view the article in the Microsoft Knowledge Base:
140991 Internet Explorer Opens .exe Files Instead of Downloading Them
For additional information about a tool to automate this process for all Microsoft Office file types, click the article number below to view the article in the Microsoft Knowledge Base:
238918 Availability of Microsoft Office Document Open Confirmation Tool

↑ Back to the top


Properties

Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

↑ Back to the top


Keywords: kbenv, kbprb, kbui, KB177976

↑ Back to the top

Article Info
Article ID : 177976
Revision : 5
Created on : 5/7/2007
Published on : 5/7/2007
Exists online : False
Views : 472