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Error Message: Unable to Install Java Packages...


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Symptoms

When you install Internet Explorer 4.0, you may receive the following error messages:
Unable to install Java Packages from c:\windows\java\classes\Xmldso.cab
Access is denied.
Unable to install Java Packages from c:\windows\system\Iejava.cab
Access is denied.
Unable to install Java Packages from c:\windows\Dajava.cab
Access is denied.

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Cause

These error messages can occur for any of the following reasons:
  • There is a copy of the Imagehlp.dll file in the Windows folder. Internet Explorer installs an updated copy of the Imagehlp.dll file in the Windows\System or Winnt\System32 folder.

  • You are trying to install Internet Explorer 4.0 over a pre-released version of Internet Explorer 4.0 that includes the Microsoft virtual machine (Microsoft VM).
  • There is an invalid certificate on the hard disk when you install Internet Explorer 4.0.
  • The Active Content security options are disabled in Internet Explorer 3.02 before you upgrade to Internet Explorer 4.0.

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Resolution

This problem no longer occurs in Internet Explorer 4.01 Service Pack 1. To obtain Internet Explorer 4.01 Service Pack 1, please visit the following Microsoft Web site: To work around this issue, use the appropriate method, below:

Rename the Imagehlp.dll File in the Windows Folder

For information about how to rename a file, click Start, click Help, click the Index tab, type "renaming" (without quotation marks), and then double- click the "Renaming files" topic.

NOTE: You must reinstall Internet Explorer 4.0 after you rename the Imagehlp.dll file.

Remove Java Before Reinstalling Internet Explorer 4.0

NOTE: You should always uninstall beta versions of software before installing the release version.

If these error messages occur when you install over a pre-released version of Internet Explorer 4.0, uninstall the previous version before installing Internet Explorer 4.0. To do this, follow these steps:
  1. Uninstall your previous version of Internet Explorer 4.0. For information about uninstalling Internet Explorer 4.0, see the following article in the Microsoft Knowledge Base:
    174265 How to Uninstall Internet Explorer 4.0
    NOTE: Do not remove the Microsoft VM if you are installing over the Internet. If you receive the following prompt, click No to keep the Microsoft VM:
    Microsoft VM Uninstall
    If this component is uninstalled. Microsoft Internet Explorer 4.0 will not be able to download files from the World Wide Web. Do you want to uninstall the Microsoft VM?
  2. Delete the following folder:
    <windir>\Java\Packages
    where <windir> is the folder where Windows is installed.

    For information about how to delete a folder, click Start, click Help, click the Index tab, type "deleting" (without quotation marks), and then double-click the "folders" topic.
  3. If you have an invalid or beta certificate for Java, follow these steps:

    1. On the View menu, click Internet Options.
    2. On the Content tab under Certificates, click Publishers.
    3. Click the certificate you want to remove, and then click Remove.
    4. Click OK, and then click OK again.

      NOTE: Beta versions of Internet Explorer used Internet Explorer BETA Publishing Division instead of Microsoft Corporation. This certificate should be removed when you Uninstall the beta version of Internet Explorer 4.0. If it is not removed, the final version of Internet Explorer 4.0 will report "Access Denied" when installing the Microsoft VM.
  4. Install Internet Explorer 4.0.

    For information about installing Internet Explorer 4.0, see the following article in the Microsoft Knowledge Base:
    170993 How to Install Internet Explorer 4.0
NOTE: After you uninstall Internet Explorer 4.0, any certificates obtained after you installed Internet Explorer 4.0 are removed.

For information about certificates in Internet Explorer 4.0, see the following article in the Microsoft Knowledge Base:
174920 Uninstalling Internet Explorer 4.0 Removes Certificates

Enable Active Content Before You Install Internet Explorer 4.0

If these error messages occur when you install over Internet Explorer 3.02, uninstall Internet Explorer 4.0 then enable the Active Content in Internet Explorer 3.02. To enable Active Content, follow these steps:
  1. In Internet Explorer 3.02, on the View menu, click Options.
  2. Click the Security Tab.
  3. Under Active Content, click the check box for the following options to select them:

    • Allow Downloading Of Active Content
    • Enable ActiveX Controls And Plug-Ins
    • Run ActiveX Scripts
    • Enable Java Programs
  4. Click OK.
  5. Install Internet Explorer 4.0.

    For information about installing Internet Explorer 4.0, see the following article in the Microsoft Knowledge Base:
    170993 How to Install Internet Explorer 4 and Troubleshoot Setup
If Internet Explorer 4.0 is already installed and these error messages occur, use the following steps to properly install Java:

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
  1. Delete the Code Download data name under the following registry key:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ Internet Settings
  2. Reinstall the Microsoft virtual machine add-on from the Internet Explorer Component Download Web page.

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More information

For more information about the Microsoft VM in Internet Explorer, see the following articles in the Microsoft Knowledge Base:

168941 INFO: Frequently Asked Questions for CAB Files kbcrossref For additional information about how to determine which folder Windows is installed in, click the article number below to view the article in the Microsoft Knowledge Base:
305792 How to Determine Which Folder Windows Is Installed In

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Properties

Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

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Keywords: kberrmsg, kbfaq, kbsetup, KB175133

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Article Info
Article ID : 175133
Revision : 8
Created on : 6/5/2007
Published on : 6/5/2007
Exists online : False
Views : 569