Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Only Desktop Wallpaper Appears When You Start Your Computer


View products that this article applies to.

Symptoms

When you restart your computer after you install Internet Explorer 4.0 or change folder options, only your desktop wallpaper may be displayed (the Start button, taskbar, and desktop icons may not be displayed).

↑ Back to the top


Cause

This behavior can occur if the Windows Desktop Update is installed and either of the following conditions exists:

  • You install Internet Explorer 4.0 on a Compaq computer running Windows 95 and using Cpqshell instead of Windows Explorer as the interface (or "shell"). This problem is caused by the interaction between Compaq's Home Base user interface shell and Internet Explorer 4.0.

    NOTE: Some Compaq Presario computers are pre-configured to use Cpqshell.
  • You changed Advanced settings on the View tab of Folder Options properties in a "rooted" instance of Windows Explorer. For example, you enabled Show All Files instead of "Do not show hidden or system files" under Hidden Files.

    NOTE: You can use any of the following methods to run a "rooted" instance of Windows Explorer:

    • Click Start, point Settings, click Taskbar & Start Menu, click the Start Menu Programs tab, and then click Advanced. This applies to Windows 95 only.
    • Start MSN, The Microsoft Network, version 1.x. This problem does not occur with MSN 2.x, which uses Internet Explorer instead of Windows Explorer. This applies to Windows 95 only.
    • You start Windows Explorer using the /root command-line switch. For information about using the /root command-line switch with Windows Explorer, please see the following articles in the Microsoft Knowledge Base:
      130510 Command-Line Switches for Windows Explorer

      152457 Windows NT Explorer Command-Line Options
      NOTE: This applies to both Windows 95 and Windows NT 4.0.
    • You right-click an area on the desktop or Windows Explorer, and then click Explorer From Here. Power Toys includes an Explore From Here shell extension that runs a "rooted" instance of Windows Explorer.

↑ Back to the top


Resolution

To resolve this problem, follow the steps in the appropriate section below:

Running Windows 95 on a Compaq Computer Using Cpqshell or Home Base

While this problem does not cause damage or data loss, you must manually restart your computer three times in order to complete the Windows Desktop Update component installation. To resolve this problem, perform each of the following methods (if needed) in the order in which they are listed below:

Method 1

  1. Press CTRL+ESC to start Windows Task Manager.
  2. On the File menu, click Shutdown Windows.
  3. Click Restart, and then click Yes.
NOTE: You may need to repeat this process three times.

If this method does not resolve the problem, use Method 2 below.

Method 2

NOTE: This method is required if you have reinstalled the Compaq OEM version of Windows 95.
  1. Press CTRL+ESC to start Windows Task Manager.
  2. On the Options menu, click Always on Top to deselect it.
  3. On the File menu, click Run Application.
  4. In the Open box, type command, and then click OK.
  5. At the command prompt, type the following command, and then press ENTER:
    copy explorer.exe microsoftexplorer.exe
  6. At the command prompt, type exit, and then press ENTER.
  7. On the File menu, click Shutdown Windows.
  8. Click Restart, and then click Yes.
After you log on to Compaq Home Base, the Start button, taskbar, and desktop icons should display and function normally. If this is not the case, use Method 3 below.

Method 3

NOTE: This method disables the Compaq Cpqshell interface.
  1. Press CTRL+ESC to start Windows Task Manager.
  2. On the Options menu, click Always on Top to deselect it.
  3. On the File menu, click Run Application.
  4. In the Open box, type sysedit, and then click OK.
  5. On the Window menu, click System.ini.
  6. In the [Boot] section of System.ini, place a semi-colon before the Shell=<path>\CPQSHELL.EXE line, and then add a Shell=Explorer.exe line as follows:
    ;Shell=<path>\CPQSHELL.EXE
          Shell=Explorer.exe
  7. On the File menu, click Exit.
  8. Click Yes.
  9. On the File menu, click Shutdown Windows.
  10. Click Restart, and then click Yes.
  11. When you receive the following prompt, click No:
    Do you wish to keep your Compaq software working?

Folder Options Changed in a "Rooted" Windows Explorer

This problem only occurs when you log on to Windows as the user who changed folder Options in the "rooted" instance of Windows Explorer. If you log on to Windows (Windows 95 or Windows NT) as a different user or start in Safe mode (Windows 95 only), this problem does not occur. To work around this problem, follow the steps in the appropriate section below:

Windows 95:

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall Windows 95. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

NOTE: For information about how to edit the registry, view the Changing Keys And Values online Help topic in Registry Editor (Regedit.exe). Note that you should make a backup copy of the registry files (System.dat and User.dat) before you edit the registry.

  1. Press CTRL+ESC to start Windows Task Manager.
  2. On the File menu, click Run Application.
  3. In the Open box, type "regedit" (without quotation marks), and then click OK.
  4. Delete the Settings binary value under the following registry key:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion \Explorer\CabinetState
  5. On the Registry menu, click Exit.
  6. Press CTRL+ALT+DELETE, and then click Shut Down.
  7. Restart your computer.
Windows NT 4.0:

WARNING: Using Registry Editor incorrectly can cause serious, system-wide problems that may require you to reinstall Windows NT to correct them. Microsoft cannot guarantee that any problems resulting from the use of Registry Editor can be solved. Use this tool at your own risk.
  1. Press CTRL+ALT+DEL, and then click Task Manager.
  2. On the File menu, click New Task (Run...).
  3. In the Open box, type regedit, and then click OK.
  4. Delete the Settings binary value under the following registry key:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion \Explorer\CabinetState
  5. On the Registry menu, click Exit.
  6. Press CTRL+ALT+DELETE, and then click Shut Down.
  7. Click Shutdown And Restart, and then click OK.

↑ Back to the top


Status

This problem does not occur in Internet Explorer 4.01 or later. To install the latest version of Internet Explorer, visit the following Microsoft Web site: For more information about this issue on Compaq computers, visit the following Compaq Web site:

↑ Back to the top


More information

If either of the resolutions above do not resolve this problem, follow these steps (Windows 95 only):
  1. Press CTRL+ESC to start Windows Task Manager.
  2. On the File menu, click Run Application.
  3. In the Open box, type system.ini, and then click OK.
  4. Verify that the following line exists in the [Boot] section of the System.ini file:
    Shell=Explorer.exe
    If the "Shell=" line contains a different file name, change it to Explorer.exe.
  5. On the File menu, click Exit, and then click Yes when you are prompted to save the changes.
  6. In Task Manager, click Shutdown Windows on the File menu, and then restart your computer.
If you are still unable to resolve this problem, uninstall Internet Explorer 4.0. For information about how to do so, please see the following articles in the Microsoft Knowledge Base: 166313 Removing Internet Explorer 4.0 for Windows 95 Using Ieremove.exe



175610 How to Manually Uninstall Internet Explorer 4.0

↑ Back to the top


Properties

Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

↑ Back to the top


Keywords: kbenv, kbfaq, kbui, KB174486

↑ Back to the top

Article Info
Article ID : 174486
Revision : 6
Created on : 6/5/2007
Published on : 6/5/2007
Exists online : False
Views : 555