Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Internet Explorer Does Not Start


View products that this article applies to.

Symptoms

When you attempt to start Internet Explorer, the mouse pointer may change to the Working In Background or Busy pointer and then back to the normal pointer, but Internet Explorer may not start.

↑ Back to the top


Cause

The EnforceShellExtensionSecurity registry option has been set and Internet Explorer does not register itself as an approved shell extension in the registry.

↑ Back to the top


Resolution

To resolve this issue, create a file named Enabie3.reg that contains the following four lines:
   REGEDIT4

   [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell
   Extensions\Approved]
   "{5E6AB780-7743-11CF-A12B-00AA004AE837}"="Microsoft Internet Toolbar"
   "{3DC7A020-0ACD-11CF-A9BB-00AA004AE837}"="The Internet"
				
After you create and save this file, double-click it in Windows NT Explorer. A message will appear stating that the information in the Enabie3.reg file has been entered into the registry.

↑ Back to the top


Status

Microsoft is researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

↑ Back to the top


More information

To restrict which shell extensions can be run on a Windows NT server or workstation, you can add "EnforceShellExtensionSecurity=0x1" to the following registry key using a policy or Registry Editor:
HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
However, Internet Explorer does not resister itself in the following key
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Approved
and as a result is unable to run.

↑ Back to the top


Properties

Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

↑ Back to the top


Keywords: kbenv, KB166465

↑ Back to the top

Article Info
Article ID : 166465
Revision : 6
Created on : 6/5/2007
Published on : 6/5/2007
Exists online : False
Views : 678