Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

MTA generates error message because of corrupted or missing .tpl file


View products that this article applies to.

Symptoms

In Exchange Server 4.0, 5.0, and 5.5, when you start the Exchange Server message transfer agent (MTA), you may receive the following error message:
Could not start the Exchange Message Transfer Agent service on \\server_name.
Error 2140: An internal Windows NT error occurred.
The following stop error message may be logged in the Application event log in Event Viewer:
Event ID 9400 MSExchangeMTA
An MTA fatal error has occurred. The file file_name.TPL could not be opened. [BASE MAIN BASE 1] (16)
The MTA cannot start at this point.

In Exchange 2000 Server, the MTA Stacks service may stop responding and you may receive the following error message:
Could not start the Microsoft Exchange MTA Stacks service on local_computer. The service did not return an error. This could be an internal Windows error or an internal service error. If the problem persists, contact your system administrator.
There may be no events logged in the Application or System event logs.

↑ Back to the top


Cause

This issue can occur if a .tpl file is missing or corrupted.

The 9400 error message contains a file name (Bind.tpl, Rose.tpl, Common.tpl, and so on). This file should be located in the Exchsrvr\Mtadata folder, but the file may be missing or corrupted.

↑ Back to the top


Resolution

To resolve this issue:
  1. Identify the file in the error message and see if the file is located in the Exchsrvr\Mtadata folder.
  2. If the file is there, rename the file in File Manager.
  3. Whether the file is in the Exchsrvr\Mtadata folder or not, copy a new instance of the file from the Setup\CPU_type\Mtadata folder that is located on the Exchange Server compact disc.
  4. After copying the file to the computer, right-click the file in the Exchsrvr\Mtadata folder, and then click Properties.
  5. On the General tab, click to clear the Read-only check box, and then click OK.
  6. Restart the MTA service.

↑ Back to the top


Properties

Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

↑ Back to the top


Keywords: KB154385, kbusage, kbprb, kberrmsg

↑ Back to the top

Article Info
Article ID : 154385
Revision : 10
Created on : 4/19/2011
Published on : 4/19/2011
Exists online : False
Views : 473