Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive a "This file is locked" error message when you try to save or close a shared file


View products that this article applies to.

Symptoms

When you save or close a shared workbook, you may receive the following error message:
This file is locked. Try the command again later.

↑ Back to the top


Cause

This behavior may occur when the shared workbook is open in Microsoft Quick View or when you are attempting to save the workbook while another user is opening the file in Microsoft Excel.

Case 1: The Shared Workbook Is Open in Microsoft Quick View

This behavior occurs if the file you are saving or closing is open in Microsoft Quick View. Quick View is a program that is included with Microsoft Windows 98. Quick View allows you to view a document without opening it in the program that was used to create the document. When you open a nonshared file in Excel, you cannot open the same file in Quick View because the file is locked by Excel. However, when you open a shared file in Excel, the file is not locked (to allow sharing), and you can view it in Quick View. When you save or close a shared file in Excel, Excel locks the file for saving. If you save or close a shared file in Excel while the file is open in Quick View, you receive the error message in the "Symptoms" section because the file is locked by Quick View in this case.

NOTE: If you open a shared file in Excel, set the file attributes to read-only (from the folder window that contains the file) while the file is still open, and then save or close the file, the error message appears.

Case 2: Another User Has Opened the Shared Workbook

This behavior occurs when you save a shared workbook and another user has already opened the workbook. The error message may also appear if you share a file while another user is opening the file because sharing a file requires that you save it.

↑ Back to the top


Workaround

To work around this behavior, use the appropriate method for your situation.

Method 1: The Shared Workbook Is Open in Microsoft Quick View

Close the file in Quick View before you attempt to save the shared workbook.

Method 2: Another User Has Opened the Shared Workbook

Wait a few minutes and save the file again. The number of minutes to wait depends on the size of the file and how long it takes to open the file. As soon as the file is opened on the other user's computer, you can successfully save the file without receiving the error message.

↑ Back to the top


More information

In Quick View, when you open a nonshared workbook file that is currently open in Excel, you receive the following error message:
The file filename can not be opened for Quick View. It may be opened or locked by another application or you may not have access to it.
When you open a file in Excel, the file is opened exclusively whether the file is shared or not. After you open the file, if the file is shared, the file is considered nonexclusive. If you attempt to save a file in Excel while another user is opening the file (another instance of Excel is reading the same file), your instance of Excel is unable to lock the file to save it, and you receive the error message described in this section.

↑ Back to the top


Keywords: KB129276, kbprb, kbinterop, kberrmsg, kbweb, kbsavefile

↑ Back to the top

Article Info
Article ID : 129276
Revision : 5
Created on : 1/23/2006
Published on : 1/23/2006
Exists online : False
Views : 448