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FIX: Changes that are made to adapter handlers are not displayed unless you restart BizTalk Server 2009 Administration Console


View products that this article applies to.

Symptoms

You change the properties of some adapter handlers in Microsoft BizTalk Server 2009 Administration Console. When you restart the associated BizTalk Server host instance and update the console, the properties appear unchanged. You must restart BizTalk Server 2009 Administration Console to see the changes to the properties in the properties page of the adapter handlers.

For example, you change the "SMTP server name" property of the SMTP adapter handler from blank to "smtpserver." You restart the associated BizTalk Server host instance, and then you reopen the properties page of the SMTP adapter handler. In this example, the "SMTP server name" field is blank. The "SMTP server name" field only displays the new property after you restart BizTalk Server 2009 Administration Console.

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Cause

The issue occurs because of an error in BizTalk Server 2009 Administration Console.

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Resolution

Cumulative update information

For BizTalk Server 2009, the hotfix that resolves this issue is included in Cumulative Update 1 for BizTalk Server 2009. 

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base: 

2429050 Cumulative update package 1 for BizTalk Server 2009

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have BizTalk Server 2009 installed.

Restart requirement



You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information


This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Microsoft.biztalk.administration.snapin.dll3.8.428.23,528,59220-May-201018:35x86
Microsoft.biztalk.applicationdeployment.engine.dll3.8.428.2567,20020-May-201018:35x86
Microsoft.biztalk.explorerom.dll3.8.428.2505,72020-May-201018:35x86
Microsoft.biztalk.resourcemanagers.dll3.8.428.2198,53620-May-201018:35x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

For more information about how to use adapters in BizTalk Server 2009, visit the following Microsoft Developer Network (MSDN) website: For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:

2003907 Information on BizTalk Server hotfixes

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Keywords: kb, kbbiztalk2009presp1fix, kbbtsadmin, kbqfe, kbautohotfix, kbhotfixserver, kbexpertiseadvanced, kbsurveynew

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Article Info
Article ID : 981960
Revision : 1
Created on : 1/7/2017
Published on : 12/8/2010
Exists online : False
Views : 403