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You cannot print to multiple trays in a Remote Desktop session in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install the Remote Desktop Services role on a computer that is running Windows Server 2008 R2.
  • On a client computer, you install a printer that supports the multiple trays configuration.
  • You establish a remote desktop connection to the computer from the client computer.
  • In the Remote Desktop session, you redirect the printer by using the Terminal Services Easy Print feature.
  • In the Remote Desktop session, you try to print a multiple-page document, and you configure the use of multiple trays.
In this scenario, all printed pages are sent to the print tray that is configured for the first page. Therefore, you cannot print a document to multiple trays.

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Cause

This issue occurs because the Remote Desktop Easy Print printer driver does not include the tray selection settings when print tickets are created.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File namePrntvpt.dll
File version6.1.7600.20713
File size156,160
Date (UTC)14-May-2010
Time (UTC)01:56
Platformx64
File namePrntvpt.dll
File version6.1.7600.20713
File size120,320
Date (UTC)14-May-2010
Time (UTC)02:24
Platformx86
For all supported IA-64-based versions of Windows Server 2008 R2
File namePrntvpt.dll
File version6.1.7600.20713
File size340,480
Date (UTC)14-May-2010
Time (UTC)01:19
PlatformIA-64
File namePrntvpt.dll
File version6.1.7600.20713
File size120,320
Date (UTC)14-May-2010
Time (UTC)02:24
Platformx86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

This is also an issue in Microsoft Windows Server 2008. For more information about this issue in Windows Server 2008, click the following article number to view the article in the Microsoft Knowledge Base:

2059743 You cannot print to multiple trays in a terminal server session in Windows Server 2008

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information, visit the following Microsoft Developer Network websites: 

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_0ddeecb2f1599b1a649445c9d84eb689_31bf3856ad364e35_6.1.7600.20713_none_3a5fe2b94489575d.manifest
File versionNot applicable
File size716
Date (UTC)14-May-2010
Time (UTC)17:59
File nameAmd64_2e1c22f51f306434c0209ae23f9a4b5a_31bf3856ad364e35_6.1.7600.20713_none_ab739122f84f153c.manifest
File versionNot applicable
File size718
Date (UTC)14-May-2010
Time (UTC)17:59
File nameAmd64_microsoft-windows-p..g-printticket-win32_31bf3856ad364e35_6.1.7600.20713_none_7022ebb3d1c69dc2.manifest
File versionNot applicable
File size5,643
Date (UTC)14-May-2010
Time (UTC)04:20
File nameX86_microsoft-windows-p..g-printticket-win32_31bf3856ad364e35_6.1.7600.20713_none_1404503019692c8c.manifest
File versionNot applicable
File size4,356
Date (UTC)14-May-2010
Time (UTC)09:29
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_18cf80fc997f397e995a5fd6fbc9343d_31bf3856ad364e35_6.1.7600.20713_none_1119bcf15bba8499.manifest
File versionNot applicable
File size1,074
Date (UTC)14-May-2010
Time (UTC)17:59
File nameIa64_microsoft-windows-p..g-printticket-win32_31bf3856ad364e35_6.1.7600.20713_none_1405f42619673588.manifest
File versionNot applicable
File size5,642
Date (UTC)14-May-2010
Time (UTC)03:49
File nameX86_microsoft-windows-p..g-printticket-win32_31bf3856ad364e35_6.1.7600.20713_none_1404503019692c8c.manifest
File versionNot applicable
File size4,356
Date (UTC)14-May-2010
Time (UTC)09:29

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Keywords: kbfix, kbautohotfix, kbhotfixserver, kbsurveynew, kbqfe, kbexpertiseadvanced, kb

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Article Info
Article ID : 981871
Revision : 2
Created on : 9/20/2018
Published on : 9/20/2018
Exists online : False
Views : 367