Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A UEFI-enabled computer may "hang" at a black screen in the startup process for Windows 7 or Windows 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 7 or Windows Server 2008 R2.
  • You enable the Unified Extensible Firmware Interface (UEFI) mode on this computer.
  • Then, one of the following events occurs during the startup process:
    • You press F8 to open the Advanced Boot Options menu, and then you press ESC to cancel.
    • You start the computer from the Windows installation DVD, and then you click the Repair your computer option to start Windows Recovery Environment (WinRE).
    • A recoverable error occurs when Winload.efi or Winresume.efi is loaded, and then Windows Recovery Environment (WinRE) is started.
In the scenario, the startup process may hang (stop responding) at a black screen.

Note This issue may be more likely to occur when you have hotfix 980598 installed on the computer.

↑ Back to the top


Cause

This issue occurs because the one of the following applications does not clean up all the page table entries for the pages that were freed:
  • The Windows Operating System Loader (Winload.efi) application
  • The Windows Resume Loader (Winresume.efi) application
When the Bootmgfw.efi application tries to clean up these page table entries, this application accesses an invalid memory address and causes an access violation exception.

Note The Bootmgfw.efi application is the Windows Boot Manager application.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 or Windows Server 2008 R2 on the computer.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Setbcdlocale.dll6.1.7600.1638549,66414-Jul-200901:16x86
Winload.exe6.1.7600.20667507,38413-Mar-201007:12x86
Winresume.exe6.1.7600.20667442,73613-Mar-201007:12x86
Winload.exe6.1.7600.20667507,38413-Mar-201007:12x86
Winresume.exe6.1.7600.20667442,73613-Mar-201007:12x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Setbcdlocale.dll6.1.7600.1638562,97614-Jul-200901:41x64
Winload.efi6.1.7600.20667641,41613-Mar-201008:00Not applicable
Winload.exe6.1.7600.20667604,50413-Mar-201007:56x64
Winresume.efi6.1.7600.20667557,44813-Mar-201008:00Not applicable
Winresume.exe6.1.7600.20667518,68813-Mar-201007:56x64
Winload.efi6.1.7600.20667641,41613-Mar-201008:00Not applicable
Winload.exe6.1.7600.20667604,50413-Mar-201007:56x64
Winresume.efi6.1.7600.20667557,44813-Mar-201008:00Not applicable
Winresume.exe6.1.7600.20667518,68813-Mar-201007:56x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Setbcdlocale.dll6.1.7600.16385153,08814-Jul-200901:48IA-64
Winload.efi6.1.7600.206671,714,56813-Mar-201006:42Not applicable
Winload.efi6.1.7600.206671,714,56813-Mar-201006:42Not applicable

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about the support and implementation requirements for UEFI in the Windows operating systems, visit the following Microsoft Web site:For more information about UEFI in the Windows operating systems, visit the following Microsoft Web site:For more information, view the article in the Microsoft Knowledge Base:

980598 Windows Server 2008 R2 cannot be installed or started on a UEFI-enabled computer that has 1 TB or more of RAM

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Onenote table of contents.onetoc2Not applicable3,65616-Mar-201009:03Not applicable
Package_for_kb981275_rtm~31bf3856ad364e35~x86~~6.1.1.0.mumNot applicable1,94713-Mar-201015:21Not applicable
X86_microsoft-windows-b..environment-windows_31bf3856ad364e35_6.1.7600.20667_none_69b02e510729c86e.manifestNot applicable5,54813-Mar-201015:23Not applicable
X86_microsoft-windows-b..vironment-os-loader_31bf3856ad364e35_6.1.7600.20667_none_5b9e5158e7060a9d.manifestNot applicable4,22513-Mar-201007:41Not applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-b..environment-windows_31bf3856ad364e35_6.1.7600.20667_none_c5cec9d4bf8739a4.manifestNot applicable6,89413-Mar-201015:25Not applicable
Amd64_microsoft-windows-b..vironment-os-loader_31bf3856ad364e35_6.1.7600.20667_none_b7bcecdc9f637bd3.manifestNot applicable5,74513-Mar-201008:44Not applicable
Package_for_kb981275_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mumNot applicable2,18113-Mar-201015:21Not applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ia64_microsoft-windows-b..environment-windows_31bf3856ad364e35_6.1.7600.20667_none_69b1d2470727d16a.manifestNot applicable4,88713-Mar-201015:21Not applicable
Ia64_microsoft-windows-b..vironment-os-loader_31bf3856ad364e35_6.1.7600.20667_none_5b9ff54ee7041399.manifestNot applicable3,47713-Mar-201008:41Not applicable
Package_for_kb981275_rtm~31bf3856ad364e35~ia64~~6.1.1.0.mumNot applicable1,68313-Mar-201015:20Not applicable

↑ Back to the top


Keywords: kbexpertiseadvanced, kbfix, kbautohotfix, kbsurveynew, kbqfe, kbhotfixserver, kb

↑ Back to the top

Article Info
Article ID : 981275
Revision : 1
Created on : 1/7/2017
Published on : 10/6/2011
Exists online : False
Views : 341