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Descriptions for the Windows Installer events are missing in the Application log in Windows Server 2003


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You installed Microsoft Windows Installer (MSI) 4.5 on a computer that is running Windows Server 2003 Service Pack 2 (SP2).
  • You run the following command before you install a Windows Installer package:
    msiexec /regserver
In this scenario, the descriptions of the Windows Installer-related events in the Application log are missing when you install a Windows Installer package, and when some Windows Installer events are added. Therefore, you cannot monitor or audit the installation process. The following events are some examples of the Windows Installer events that are added:
Event Type: Error
Event Source: MsiInstaller
Event Category: None
Event ID: 11728
Description: The description for Event ID (11728) in Source (MsiInstaller) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer.
Event Type: Error
Event Source: MsiInstaller
Event Category: None
Event ID: 11707
Description: The description for Event ID (11707) in Source (MsiInstaller) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer.

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Cause

This issue occurs because an incorrect event message file is registered when you run msiexec /regserver command.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2003 Service Pack 2 (SP2). Additionally, Microsoft Windows Installer 4.5 must be installed on the computer.

For more information about how to obtain a Windows Server 2003 service pack or a Windows XP Professional x64 Edition service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 SP2 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003 SP2

File nameFile versionFile sizeDateTimePlatformSP requirement
Msi.dll4.5.6002.223094,445,69613-Jan-201015:05x86SP2
Msihnd.dll4.5.6002.22193332,80013-Jan-201015:05x86SP2
For all supported x64-based versions of Windows Server 2003 SP2

File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Msi.dll4.5.6002.223095,286,91213-Jan-201012:50x64SP2Not Applicable
Msihnd.dll4.5.6002.22193503,29613-Jan-201012:50x64SP2Not Applicable
Wmsi.dll4.5.6002.223094,445,69613-Jan-201012:50x86SP2WOW
Wmsihnd.dll4.5.6002.22193332,80013-Jan-201012:50x86SP2WOW
For all supported IA-64-based versions of Windows Server 2003

File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Msi.dll4.5.6002.223098,113,66413-Jan-201012:50IA-64SP2Not Applicable
Msihnd.dll4.5.6002.221931,085,95213-Jan-201012:50IA-64SP2Not Applicable
Wmsi.dll4.5.6002.223094,445,69613-Jan-201012:50x86SP2WOW
Wmsihnd.dll4.5.6002.22193332,80013-Jan-201012:50x86SP2WOW

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Workaround

To work around this issue, change the value of the EventMessagefile entry to the following value.
Location:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Eventlog\Application\MsiInstaller

Name:
EventMessageFile

Type:
REG_SZ

Value:
C:\WINDOWS\system32\msi.dll
After you change this value, restart the computer.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about Windows Installer 4.5, click the following article number to view the article in the Microsoft Knowledge Base:
942288 Windows Installer 4.5 is available
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbqfe, kbhotfixserver, kbsurveynew, kbautohotfix, kbexpertiseinter, kbbug, kbfix, KB979302

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Article Info
Article ID : 979302
Revision : 1
Created on : 2/10/2010
Published on : 2/10/2010
Exists online : False
Views : 286