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The SNMP service does not respond to all SNMP requests on a computer that is running Windows Server 2003 after the Group Policy settings are refreshed


View products that this article applies to.

Symptoms

Consider the following scenario:
  • The Simple Network Management Protocol (SNMP) service is installed on a computer that is running Windows Server 2003 Service Pack 2 (SP2) or an x64-based version of Windows XP Service Pack 2 (SP2).
  • You manually refresh the Group Policy settings on this computer. Or, the settings are automatically refreshed.
In this scenario, the SNMP service may not respond to the SNMP requests. You have to restart the SNMP service to recover from this issue.

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Cause

During the Group Policy refreshing process, some registry keys are deleted, and then recreated. If some delay occurs in this process, there is a long period of time between the deleting of the registry keys and the recreating of the keys.

If a registry key change notification is sent to the SNMP service in this period of time, the SNMP service cannot access the expected registry keys. Because the SNMP service does not retry to register the registry change notification, the SNMP service cannot read these registry keys after they are recreated by the Group Policy engine.

The SNMP service rejects all SNMP requests because the service cannot read some important registry values. The SNMP service registers such notifications when its service starts.

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Resolution

A hotfix is available to resolve this issue. By default, after you install this hotfix, the SNMP service retries registering the notification five times if it cannot access a registry key. You can customize the number of retries by creating a registry entry (PolicyNotificationRetries), and then set its value to the desired number of retries. For more information, see the "Registry information" section.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2003 Service Pack 2 (SP2) or an x64-based version of Windows XP Service Pack 2 (SP2). Additionally, the Simple Network Management Protocol (SNMP) service must be installed on the computer.

Restart requirement

You must restart the computer if the SNMP service is running when this hotfix is installed. If you stop the SNMP service before you install this hotfix, you do not have to restart the computer.

Registry information

You can customize the number of retries by creating the following registry entry:
Name: PolicyNotificationRetries
Location: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SNMP\Parameters
Type: REG_DWORD
Default value: 5
Note The value of the PolicyNotificationRetries item indicates the number of retries. If you set the value to 10, the SNMP service retries up to 10 times to register the registry change notification.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Snmp.exe5.2.3790.454341,47203-Jul-200911:46x86
For all supported Itanium-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Snmp.exe5.2.3790.4543116,73603-Jul-200919:46IA-64SP2Not Applicable
Wsnmp.exe5.2.3790.454341,47203-Jul-200919:46x86SP2WOW
For all supported x64-based versions of Windows Server 2003 SP2 and of Windows XP SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Snmp.exe5.2.3790.454361,44003-Jul-200919:46x64SP2Not Applicable
Wsnmp.exe5.2.3790.454341,47203-Jul-200919:46x86SP2WOW

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Workaround

To work around the issue, restart the SNMP service.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 � Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, KB972840

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Article Info
Article ID : 972840
Revision : 2
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 375