Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: You are prompted to format the volume when a formatted volume is mounted on a NTFS folder that is located on a computer that is running Windows Server 2008 or Windows Vista


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You create a folder on an NTFS file system volume on a computer that is running Windows Server 2008 or Windows Vista.
  • You configure this folder as a reparse point or as a mount point for volumes that will be added.
  • A formatted volume is mounted on the folder.
Under a stress situation in this scenario, you are prompted with the following message when the volume is mounted to the reparse point or to the mount point:
You need to format the disk in drive <drive letter> before you can use it.
Do you want to format it?
If you click the Format disk button in the message dialog box, the wrong volume is formatted. For example, when you mount a volume on the E:\mount folder, you receive the message that is mentioned in the "Symptoms" section. If you click the Format disk button, volume E is formatted instead of the mounted volume.

↑ Back to the top


Cause

Under a stress situation, the Windows message change notifications may be asynchronous for Plug and Play (PNP) devices. This behavior leads to a timing issue. When this timing issue occurs, the Shell Hardware Detection service receives a volume name-change notification after the volume is deleted.

The Shell Hardware Detection service assumes that the globally unique identifier (GUID) of the related volume exists when the service handles a name change notification. However, this assumption is invalid when the timing issue occurs. Therefore, the change notification is handled incorrectly, and the behavior that is mentioned in the "Symptoms" section occurs.

↑ Back to the top


Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must be running one of the following operating systems:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista SP1
File nameFile versionFile sizeDateTimePlatform
Shsvcs.dll6.0.6001.22469247,80813-Jul-200911:46x86
For all supported x86-based versions of Windows Server 2008 SP2 and of Windows Vista SP2
File nameFile versionFile sizeDateTimePlatform
Shsvcs.dll6.0.6002.22171247,80813-Jul-200911:43x86
For all supported Itanium-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Shsvcs.dll6.0.6001.22469497,15213-Jul-200913:09IA-64
For all supported Itanium-based versions of Windows Server 2008 SP2
File nameFile versionFile sizeDateTimePlatform
Shsvcs.dll6.0.6002.22171497,15213-Jul-200911:37IA-64
For all supported x64-based versions of Windows Server 2008 and of Windows Vista SP1
File nameFile versionFile sizeDateTimePlatform
Shsvcs.dll6.0.6001.22469302,08013-Jul-200912:14x64
For all supported x64-based versions of Windows Server 2008 SP2 and of Windows Vista SP2
File nameFile versionFile sizeDateTimePlatform
Shsvcs.dll6.0.6002.22171302,08013-Jul-200911:41x64


↑ Back to the top


Workaround

To work around this issue, when you are prompted with the message dialog box that is mentioned in the "Symptoms" section, click Cancel to close the message dialog box and to prevent the incorrect formatting action.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates


Additional file information for Windows Server 2008 and for Windows Vista

Additional files for all supported x86-based versions of Windows Server 2008 and of Windows Vista

File nameFile versionFile sizeDateTimePlatform
Package_for_kb971254_client_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,36713-Jul-200917:50Not Applicable
Package_for_kb971254_client_2~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,53013-Jul-200917:50Not Applicable
Package_for_kb971254_client~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,71213-Jul-200917:50Not Applicable
Package_for_kb971254_server_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,42513-Jul-200917:50Not Applicable
Package_for_kb971254_server_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,53013-Jul-200917:50Not Applicable
Package_for_kb971254_server~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,71313-Jul-200917:50Not Applicable
X86_microsoft-windows-shsvcs_31bf3856ad364e35_6.0.6001.22469_none_cd8222b93633b9d6.manifestNot Applicable12,48713-Jul-200913:22Not Applicable
X86_microsoft-windows-shsvcs_31bf3856ad364e35_6.0.6002.22171_none_cf55c26533696033.manifestNot Applicable12,48713-Jul-200912:59Not Applicable

Additional files for all supported Itanium-based versions of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
Ia64_microsoft-windows-shsvcs_31bf3856ad364e35_6.0.6001.22469_none_cd83c6af3631c2d2.manifestNot Applicable12,50413-Jul-200914:28Not Applicable
Ia64_microsoft-windows-shsvcs_31bf3856ad364e35_6.0.6002.22171_none_cf57665b3367692f.manifestNot Applicable12,50413-Jul-200912:41Not Applicable
Package_for_kb971254_server_0~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,42913-Jul-200917:50Not Applicable
Package_for_kb971254_server_1~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,37013-Jul-200917:50Not Applicable
Package_for_kb971254_server~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,71613-Jul-200917:50Not Applicable

Additional files for all supported x64-based versions of Windows Server 2008 and of Windows Vista

File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-shsvcs_31bf3856ad364e35_6.0.6001.22469_none_29a0be3cee912b0c.manifestNot Applicable12,52113-Jul-200913:47Not Applicable
Amd64_microsoft-windows-shsvcs_31bf3856ad364e35_6.0.6002.22171_none_2b745de8ebc6d169.manifestNot Applicable12,52113-Jul-200912:55Not Applicable
Package_for_kb971254_client_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,37513-Jul-200917:50Not Applicable
Package_for_kb971254_client_2~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,54013-Jul-200917:50Not Applicable
Package_for_kb971254_client~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,72213-Jul-200917:50Not Applicable
Package_for_kb971254_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43313-Jul-200917:50Not Applicable
Package_for_kb971254_server_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,54013-Jul-200917:50Not Applicable
Package_for_kb971254_server~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,72313-Jul-200917:50Not Applicable

↑ Back to the top


Keywords: kbhotfixserver, kbautohotfix, kbexpertiseadvanced, kbqfe, kbsurveynew, KB971254

↑ Back to the top

Article Info
Article ID : 971254
Revision : 2
Created on : 10/26/2009
Published on : 10/26/2009
Exists online : False
Views : 347