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FIX: Event ID 14014 is logged in the BizTalk Server Application log and BAM Alerts are not sent as expected


View products that this article applies to.

Symptoms

In Microsoft BizTalk Server, Business Activity Monitoring (BAM) Alerts do not work as expected. Additionally, an Error event that resembles the following is logged in the Application log:


Event Type: Error
Event Source: Bam
Event Provider
Event Category: None
Event ID: 14014
Description:
Retrieving updated events from bam db. Encountered error: System.Data.SqlClient.SqlException: Transaction (Process ID <number>) was deadlocked on lock resources with another process and has been chosen as the deadlock victim. Rerun the transaction. at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection) ...

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Cause

This problem occurs because of problems in some stored procedures that are related to BAM Alerts. These problems cause deadlocks in the BAMAlertsApplication database.

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Resolution

Cumulative updated information

For BizTalk Server 2009, the hotfix that resolves this issue is included in Cumulative Update 1 for BizTalk Server 2009.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:

2429050� Cumulative update package 1 for BizTalk Server 2009

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Microsoft BizTalk Server 2006 R2 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

How to install this hotfix

  1. Extract the hotfix package to a folder.
  2. Run the setup.exe file on all BizTalk Server(s) in the group to update the binaries.
  3. Stop all BizTalk services, and then run the ApplyQfe3248.sql file against the BAM Alerts Application Database to update the database.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.biztalk.bam.management.dll3.6.1529.23,344,25630-Apr-200910:31x86
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about how to configure BAM Alerts by using the Configuration Manager, visit the following Microsoft Web sites:

http://technet.microsoft.com/en-us/library/aa546832.aspx

http://msdn.microsoft.com/en-us/library/dd800196.aspx

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Keywords: kbsurveynew, kbautohotfix, kbbiztalk2006r2sp1fix, kbexpertiseinter, kbHotfixServer, kbqfe, kbbiztalk2009presp1fix, KB969217

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Article Info
Article ID : 969217
Revision : 3
Created on : 12/8/2010
Published on : 12/8/2010
Exists online : False
Views : 633