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A Windows Server 2003 SP2-based computer stops responding when you move lots of files from one directory to another


View products that this article applies to.

Symptoms

A Windows Server 2003 Service Pack 2 (SP2)-based computer may stop responding for some time when you move lots of files (about 5000 files) from one directory to another one.

When this issue occurs, the response to a mouse click or to a screen update is significantly slower. Also, you cannot use terminal sessions to connect to the computer.

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Cause

The move operation checks whether any user has handles to the newly created files or directories in or under the directory from which the files are being moved (the "source directory"). A Volume Control Block (VCB) lock is acquired exclusively during the process, and any other I/O requests to the volume are blocked.

However, this process may take an unnecessarily long time if the number of newly created files in or under the source directory is large. The server stops responding for a long time and then eventually recovers.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must have Windows Server 2003 SP2 installed.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003 SP2, x86-based versions

File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.4481592,38423-Mar-200912:16x86

Windows Server 2003 SP2, Itanium-based versions

File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.44811,890,81623-Mar-200917:34IA-64

Windows Server 2003 SP2 and Windows XP SP2, x64-based versions

File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.44811,046,01623-Mar-200917:38x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, KB962965

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Article Info
Article ID : 962965
Revision : 2
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 240