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Stop error that is related to the Storport.sys driver on a Windows Server 2003-based computer: "0x000000D1 (parameter1, parameter2, parameter3, parameter4) DRIVER_IRQL_NOT_LESS_OR_EQUAL"


View products that this article applies to.

Symptoms

On a Windows Server 2003-based computer, you receive the following Stop error message on a blue screen:
0x000000D1 (parameter1, parameter2, parameter3, parameter4) DRIVER_IRQL_NOT_LESS_OR_EQUAL
Notes
  • The parameters in this error message vary, depending on the computer's configuration.
  • Not all "0x000000D1" Stop errors are caused by this problem.
This problem occurs when the Storport.sys driver is called to pause or to resume an adapter in a Windows Server 2003-based computer. Additionally, storage driver developers may encounter symptoms of this issue when their drivers perform similar operations.

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Cause

This problem occurs because the Storport.sys system driver passes incorrect parameters to the StorPortResume function and to the StorPortPause function. Therefore, the system experiences the Stop error, and then the computer restarts unexpectedly.

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Resolution

Hotfix information for Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed.
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86 version
File nameFile versionFile sizeDateTimePlatformSP requirement
Diskdump.sys5.2.3790.304418,94414-Nov-200711:59x86SP1
Storport.sys5.2.3790.3044108,03214-Nov-200711:59x86SP1
Windows Server 2003 with Service Pack 2, x86 version
File nameFile versionFile sizeDateTimePlatformSP requirement
Diskdump.sys5.2.3790.418918,94414-Nov-200712:20x86SP2
Storport.sys5.2.3790.4189108,03214-Nov-200712:20x86SP2
Windows Server 2003, x64 version
File nameFile versionFile sizeDateTimePlatformSP requirement
Diskdump.sys5.2.3790.304424,06414-Nov-200715:27x64SP1
Storport.sys5.2.3790.3044188,41614-Nov-200715:27x64SP1
Windows Server 2003 with SP2, x64 version
File nameFile versionFile sizeDateTimePlatformSP requirement
Diskdump.sys5.2.3790.418924,06414-Nov-200715:31x64SP2
Storport.sys5.2.3790.4189188,92814-Nov-200715:31x64SP2
Windows Server 2003 with Service Pack 1, IA-64 version
File nameFile versionFile sizeDateTimePlatformSP requirement
Diskdump.sys5.2.3790.304449,66414-Nov-200715:27IA-64SP1
Storport.sys5.2.3790.3044347,13614-Nov-200715:27IA-64SP1
Windows Server 2003 with Service Pack 2, IA-64 version
File nameFile versionFile sizeDateTimePlatformSP requirement
Diskdump.sys5.2.3790.418949,66414-Nov-200715:27IA-64SP2
Storport.sys5.2.3790.4189347,13614-Nov-200715:27IA-64SP2

Hotfix information for Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 1 or Windows XP Service Pack 2 installed.
322389 How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP Professional, x64 Edition
File nameFile versionFile sizeDateTimePlatformSP requirement
Diskdump.sys5.2.3790.304424,06414-Nov-200715:27x64SP1
Storport.sys5.2.3790.3044188,41614-Nov-200715:27x64SP1
Windows XP Professional x64 Edition with SP2, x64 version
File nameFile versionFile sizeDateTimePlatformSP requirement
Diskdump.sys5.2.3790.418924,06414-Nov-200715:31x64SP2
Storport.sys5.2.3790.4189188,92814-Nov-200715:31x64SP2

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the "DRIVER_IRQL_NOT_LESS_OR_EQUAL" error message, visit the following Microsoft Web site:For more information about the StorPortResume function, visit the following Microsoft Web site:For more information about the StorPortPause function, visit the following Microsoft Web site:

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Keywords: KB945119, kbexpertisebeginner, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 945119
Revision : 3
Created on : 11/30/2007
Published on : 11/30/2007
Exists online : False
Views : 402