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A Windows Server 2003-based computer stops responding when the system is under a heavy load and when the Storport driver is being used


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You are running a Windows Server 2003-based computer under a heavy load.
  • The Storport driver is being used.
  • The Emulex elxstor driver is installed on the computer.
In this scenario, the computer stops responding.

In a typical instance of this problem, Microsoft SQL Server is installed on the computer. In this situation, the following message is logged in the SQL Server Errorlog file:
SQL Server has encountered 20 occurrence(s) of I/O requests taking longer than 15 seconds to complete on file <File path and name> in database <Database name>. The OS file handle is <Handle number>. The offset of the latest long I/O is: <Address>

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Cause

If the device queue is paused, the Storport.sys driver may cause a miniport driver to leak memory for each I/O request. This leaked memory accumulates very quickly, and eventually the computer stops responding.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Diskdump.sys5.2.3790.301318,94421-Sep-200711:55x86SP1
Storport.sys5.2.3790.3013107,52021-Sep-200711:55x86SP1
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Diskdump.sys5.2.3790.415618,94421-Sep-200712:10x86SP2
Storport.sys5.2.3790.4156107,52021-Sep-200712:10x86SP2
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Diskdump.sys5.2.3790.301349,66421-Sep-200714:03IA-64SP1
Storport.sys5.2.3790.3013343,04021-Sep-200714:03IA-64SP1
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Diskdump.sys5.2.3790.415624,06421-Sep-200715:13x64SP2
Storport.sys5.2.3790.4156187,39221-Sep-200715:13x64SP2
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Diskdump.sys5.2.3790.301324,06421-Sep-200714:02x64SP1
Storport.sys5.2.3790.3013186,36821-Sep-200714:02x64SP1
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Diskdump.sys5.2.3790.415624,06421-Sep-200715:13x64SP2
Storport.sys5.2.3790.4156187,39221-Sep-200715:13x64SP2

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbHotfixServer, kbqfe, KB941276

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Article Info
Article ID : 941276
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 276