Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive a Stop error message after you install update 932755 or 941276 on an HP ProLiant server that is running Storport in Windows Server 2003


View products that this article applies to.

Symptoms

On an HP ProLiant server that is running the Microsoft Storport storage driver (Storport.sys) in Microsoft Windows Server 2003, you may receive a Stop error message that resembles one of the following error messages.

Error message 1

*** STOP: 0x000000D1 (parameter1, parameter2, parameter3, parameter4)
DRIVER_IRQL_NOT_LESS_OR_EQUAL

Error message 2

*** STOP: 0x00000050 (parameter1, parameter2, parameter3, parameter4)
PAGE_FAULT_IN_NONPAGED_AREA

Error message 3

*** STOP: 0x00000024 (parameter1, parameter2, parameter3, parameter4)
NTFS_FILE_SYSTEM

Error message 4

*** STOP: 0x000000A0 (parameter1, parameter2, parameter3, parameter4)
INTERNAL_POWER_ERROR

Error message 5

*** STOP: 0x000000C5 (parameter1, parameter2, parameter3, parameter4)
DRIVER_CORRUPTED_EXPOOL
This problem may occur if the following conditions are true:
  • The computer is configured by using an HP Smart Array SAS/SATA controller.
  • The computer is operating under high I/O activity for an extended time.
  • The computer is running the following software or drivers:
    • The HP Insight Management Storage Agents software
    • Hpcisss2.sys driver version 6.6.0.32 for x86
    • Hpcisss2.sys driver 6.6.0.64 for x64
    • Earlier versions of the Hpcisss2.sys driver
    • One of the following:
      • Microsoft Windows Server 2003 Service Pack 1 (SP1) and the update that is described in Microsoft Knowledge Base article 932755 or 941276. For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
        932755 An updated Storport storage driver (version 5.2.3790.4021) is available for Windows Server 2003
        941276 A Windows Server 2003-based computer stops responding when the system is under a heavy load and when the Storport driver is being used
      • Microsoft Windows Server 2003 Service Pack 2 (SP2) and update 932755 or 941276.
For more information about this issue, visit the HP Web site.

↑ Back to the top


Cause

This problem occurs because the Storport storage driver that is included in Windows Server 2003 SP2, in update 932755, and in update 941276 is incompatible with HP driver Hpcisss2.sys. This problem occurs because this update to the Storport driver exposes an issue with I/O Control (IOCTL) calls that are made by the HP Insight Management Storage Agents.

↑ Back to the top


Resolution

To resolve this issue, contact HP to obtain the latest HP ProLiant Support Pack for Microsoft Windows Server 2003 or to obtain an update to HP driver Hpcisss2.sys. For information about how to contact HP, visit the following Microsoft Web site:

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

↑ Back to the top


Keywords: kbprb, kbexpertiseadvanced, kbtshoot, KB940015

↑ Back to the top

Article Info
Article ID : 940015
Revision : 6
Created on : 6/30/2008
Published on : 6/30/2008
Exists online : False
Views : 285