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A new physical disk resource does not successfully move to another cluster node on a Windows Server 2003-based server cluster


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Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows registry

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Symptoms

When you try to move a physical disk resource from one cluster node to another cluster node on a Microsoft Windows Server 2003-based server cluster, the move operation is unsuccessful.

When this problem occurs, information that resembles the following is logged in the %WINDIR%\Cluster.log file:
INFO [CP] CppResourceNotify for resource Restore Volume
INFO Physical Disk <Disk JM:>: [DiskArb]------- DisksOnline -------.
INFO Physical Disk <Disk JM:>: [DiskArb] DisksOpenResourceFileHandle: Attaching to 
disk with signature E8AAEC81 
INFO Physical Disk <Disk JM:>: [DiskArb] DisksOpenResourceFileHandle: Disk unique 
id present trying new attach
INFO Physical Disk <Disk JM:>: [DiskArb] DisksOpenResourceFileHandle: Retrieving 
disk number from ClusDisk registry key 
ERR  Physical Disk <Disk JM:>: Online: Unable to open ClusDisk signature key 
e8aaec81. Error: 2.
ERR  Physical Disk <Disk JM:>: Online, DisksOpenResourceFileHandle failed. Error: 
2
INFO Physical Disk <Disk JM:>: Online, setting ResourceState 4 .
INFO [RM] RmpSetResourceStatus, Posting state 4 notification for resource <Disk JM:>

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Cause

This problem occurs if the hard disk's signature is missing from the Windows registry.

When you bring a physical disk online, the following behavior occurs:
  1. Windows identifies the disk by using the disk's GUID number.
  2. Because the disk is a physical disk, Windows obtains the disk signature from the following registry location:
    HKEY_LOCAL_MACHINE\Cluster\Resources\<GUID>\Parameters
    Note In the Cluster.log file that appears in the "Symptoms" section, the disk signature is E8AAEC81.
  3. Windows obtains the DiskName value that corresponds to the signature of the physical disk. To do this, Windows examines the following registry location:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ClusDisk\Parameters\Signature\<E8AAEC81>
    The value of the DiskName registry entry indicates the device that is being brought online. For example, the DiskName registry entry may contain a value such as \Device\Harddisk5.
  4. Windows submits a request to the host bus adapter (HBA) to reserve this disk signature together with the disk number.
The log file entries that appear in the "Symptoms" section indicate that a file was not found. In this scenario, because the E8AAEC81 registry subkey is missing, Windows cannot determine which disk number to reserve. Therefore, the move operation is unsuccessful.

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Resolution

Method 1: Install the KB919117 hotfix

Install the hotfix that is mentioned in the Microsoft Knowledge Base article KB919117. For more information about this hotfix, click the following article number to view the article in the Microsoft Knowledge Base:
919117� A hotfix is available that adds support for GUID partition table (GPT) volumes that are larger than 2 terabytes on a Windows Server 2003-based server cluster

Method 2: Modify the registry

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this problem, create the registry subkey that corresponds to the disk signature of the physical disk resource with which you experience this problem. In the Cluster.log file that appears in the "Symptoms" section, this subkey is the E8AAEC81 subkey. Then, add the following registry entry to this subkey:
Name: DiskName
Type: REG_SZ
Value data: \Device\Harddisknumber
After you perform these actions, you can fail over the physical disk resource successfully. You do not have to restart the computer after you perform these actions.

To configure this registry entry, follow these steps:
  1. Examine the Cluster.log file to determine the disk signature with which you experience this problem.
  2. Click Start, click Run, type regedit, and then click OK.
  3. In Registry Editor, locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ClusDisk\Parameters\Signatures
  4. Right-click Signatures, point to New, and then click Key.
  5. Type the disk signature with which you experience the problem, and then press ENTER. For example, type E8AAEC81.
  6. Right-click the new registry subkey, point to New, and then click String Value.
  7. Type DiskName, and then press ENTER.
  8. Right-click DiskName, and then click Modify.
  9. In the Value data box, type \Device\Harddisknumber, and then click OK.

    In this registry entry, replace number with the correct number for the hard disk that you want to fail over.

    Note You can obtain this disk number by using the Disk Management tool. To do this, follow these steps:
    1. On the computer that hosts the hard disk, click Start, click Run, type diskmgmt.msc, and then click OK.
    2. In the lower pane of the Disk Management window, note the disk number that corresponds to the letter of the drive with which you experience the problem.

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More information

If you specify an incorrect disk number when you follow the steps in the "Resolution" section, information that resembles the following is logged in the Cluster.log file:
INFO [CP] CppResourceNotify for resource Restore Volume
INFO Physical Disk <Disk JM:>: [DiskArb]------- DisksOnline -------.
INFO Physical Disk <Disk JM:>: [DiskArb] DisksOpenResourceFileHandle: Attaching to 
disk with signature E8AAEC81 
INFO Physical Disk <Disk JM:>: [DiskArb] DisksOpenResourceFileHandle: Disk unique 
id present trying new attach
INFO Physical Disk <Disk JM:>: [DiskArb] DisksOpenResourceFileHandle: Retrieving 
disk number from ClusDisk registry key 
ERR  Physical Disk <Disk JM:>: Online: error opening device '\\.\PhysicalDrive22', 
Error: 2
ERR  Physical Disk <Disk JM:>: Online, DisksOpenResourceFileHandle failed. Error: 
2
INFO Physical Disk <Disk JM:>: Online, setting ResourceState 4 .
INFO [RM] RmpSetResourceStatus, Posting state 4 notification for resource <Disk 
JM:>
In this situation, you must modify the DiskName value with the correct disk number.

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Keywords: KB932465, kbprb, kbclustering, kbtshoot, kbregistry, kbdiskmemory

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Article Info
Article ID : 932465
Revision : 4
Created on : 4/24/2007
Published on : 4/24/2007
Exists online : False
Views : 510