Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Msimsp.exe utility may generate a stack error on a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

You use the Microsoft Windows Platform Software Development Kit (SDK) utility (Msimsp.exe) to generate a patch between two versions of an administrative installation on a Microsoft Windows Server 2003-based computer. When you do this, the Msimsp.exe utility may generate a stack error and immediately exit. The log file is incomplete and does not indicate the cause of the error.

↑ Back to the top


Cause

This problem occurs when the original Microsoft Windows Installer packages have a file name or a directory name that exceeds the space that is reserved for an entry.

To identify the file, the full path of a file is used together with a GUID that is appended to the file. The path+file+GUID string is put in an internal table that represents the files that are to be installed. When the space for this table entry exceeds the reserved space, this problem may occur. The file path and the GUID are put into a table so that differences between the two installations can be compared.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Patchwiz.dll3.1.4000.2672165,88831-Mar-200605:13x86

↑ Back to the top


Workaround

To work around this problem, shorten the file path of the components. If the installation is already deployed, you must apply this hotfix to generate the patch.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows Server 2003 Service Pack 2.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: KB917465, kbqfe, kbfix, kbbug, kbwinserv2003sp2fix, kbautohotfix

↑ Back to the top

Article Info
Article ID : 917465
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 239