Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A Windows Server 2003-based terminal server in a forest cannot obtain a license from a license server in a different forest


View products that this article applies to.

Symptoms

A Microsoft Windows Server 2003-based server that has Terminal Server enabled and that is located in a forest cannot obtain a license from a Terminal Server license server that is located in a different forest when those forests are connected by an external trust.

Note External trusts only support NTLM authentication. External trusts are also known as "down-level trusts" or "Microsoft Windows NT Server 4.0 trusts."

↑ Back to the top


Cause

This problem occurs because Terminal Server cannot obtain a license when NTLM is used for authentication.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, 32-bit x86-based versions
File nameFile versionFile sizeDateTimePlatform
Mstlsapi.dll5.2.3790.385106,49610-Aug-200503:02x86

Windows Server 2003, 32-bit x86-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatform
Mstlsapi.dll5.2.3790.2505118,27210-Aug-200503:13x86

Windows Server 2003, 64-bit Itanium-based versions
File nameFile versionFile sizeDateTimePlatformService branch
Mstlsapi.dll5.2.3790.385316,41609-Aug-200513:09IA-64Not Applicable
Wmstlsapi.dll5.2.3790.385106,49609-Aug-200513:09x86WOW

Windows Server 2003, 64-bit Itanium-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Mstlsapi.dll5.2.3790.2505347,64809-Aug-200513:09IA-64SP1Not Applicable
Wmstlsapi.dll5.2.3790.2505118,27209-Aug-200513:09x86SP1WOW

Windows Server 2003, 64-bit x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Mstlsapi.dll5.2.3790.2505190,97609-Aug-200513:09x64SP1Not Applicable
Wmstlsapi.dll5.2.3790.2505118,27209-Aug-200513:09x86SP1WOW

↑ Back to the top


Workaround

To work around this problem, use either of the following methods.

Method 1

Install a Terminal Server license server in the same domain or forest as the Terminal Server that is requesting the license.

For more information about license server roles, visit the following Microsoft Web site:For more information about where to install license servers for each role, visit the following Microsoft Web site:

Method 2

Create a forest trust that supports Kerberos authentication between the two forests.

For more information about forest trusts, visit the following Microsoft Web site:

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

↑ Back to the top


More information

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
279561 How to override the license server discovery process in Windows Server 2003 Terminal Services

↑ Back to the top


Keywords: kbautohotfix, kbwinserv2003sp2fix, kbbug, kbfix, kbwinserv2003presp1fix, kbHotfixServer, kbqfe, KB905687

↑ Back to the top

Article Info
Article ID : 905687
Revision : 5
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 423