Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A user receives an NDR that contains a 5.2.1 status code when the user tries to send an e-mail message to a public folder in Exchange Server 2003


View products that this article applies to.

Symptoms

You experience the following symptoms in a Microsoft Exchange Server 2003 organization:
  • Certain users cannot send e-mail messages to any public folders in your organization. However, these users can successfully post a message in a public folder. In this situation, when a user tries to send an e-mail message to a public folder, the user receives a non-delivery report (NDR) that contains a 5.2.1 status code.
  • The following events are logged in the Application log of the Exchange server:

    Event message 1

    Event ID: 327
    Event category : Exchange Store Driver
    Event source : MSExchangeTransport
    Type : Warning
    Date : date
    Time: time
    Computer: ComputerName
    Description: The following call : EcLocallyDeliverMsg2 to the store failed. Error code: 1238 (Message-ID <GUID@example.com> will be NDR'd). MDB: GUID. FID: . MID: . File : C:\Exchsrvr\Mailroot\vsi 1\Queue\NTFS_messageID.EML.

    Event message 2

    Event ID : 3013
    Event category: NDR
    Event source: MSExchangeTransport
    Type : Warning
    Date: date
    Time: time
    Computer: ComputerName
    Description: A non-delivery report with a status code of 5.2.1 was generated for recipient rfc822;user@example.com (Message-ID <messageID@ComputerName.example.com>)

↑ Back to the top


Cause

This problem occurs if the following conditions are true:
  • You have more than one domain in your Active Directory forest.
  • You are running Microsoft Windows Server 2003 Service Pack 1 (SP1) on the domain controllers in your domains.
  • The users who cannot send e-mail messages to any public folders are members of the built-in Distributed COM Users security group.
This problem occurs because Exchange Server 2003 does not recognize the Distributed COM Users group. This group is added by Windows Server 2003 SP1.

When a user who is a member of the Distributed COM Users group sends an e-mail message to a public folder in Exchange Server 2003, the following actions occur:
  • Exchange Server 2003 tries to match the Distributed COM Users group SID with an existing Active Directory group.
  • Because more than one domain exists, Exchange Server 2003 locates more than one Distributed COM Users group.
  • Exchange Server 2003 calls a function to parse an array of built-in groups to determine whether the user is a member of a built-in group. However, because the Distributed COM Users group is not contained within this array, Exchange Server 2003 cannot match the Distributed COM Users group SID with an Active Directory group.
Therefore, Exchange Server 2003 determines that the user who sends the e-mail message has an ambiguous alias. And, Exchange Server 2003 generates an NDR.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, you must be running Microsoft Exchange Server 2003 Service Pack 2 (SP2) to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, the Microsoft Exchange Information Store service and all its dependant services are automatically stopped and then restarted when you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Mdbmsg.dll6.5.7651.113,357,18420-Mar-200620:36x86
Store.exe6.5.7651.115,251,07220-Mar-200621:55x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
817903 New naming schema for Exchange Server software update packages

↑ Back to the top


Keywords: KB873393, kbbug, kbfix, kbqfe, kbHotfixServer, kbautohotfix

↑ Back to the top

Article Info
Article ID : 873393
Revision : 3
Created on : 9/10/2011
Published on : 9/10/2011
Exists online : False
Views : 547