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KB - A batch is held in the Posting, Receiving, Busy, Marked, Locked, or Edited status in Microsoft Dynamics GP


View products that this article applies to.

Symptoms

After you try to post a batch in Microsoft Dynamics GP or in Microsoft Business Solutions - Great Plains, the batch is assigned one of the following statuses:
  • Posting
  • Receiving
  • Busy
  • Marked
  • Locked
  • Edited
You cannot post or unmark the batch. When you try to open the batch, you may receive the following error message:
"Batch is marked for posting by another user."
This problem occurs when you use Microsoft Dynamics GP together with Microsoft SQL Server.

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Cause

This issue may occur because a power fluctuation or some other problem caused the posting process to stop.

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Resolution

To fix the problem, use one of the options below. To have us fix this problem for you, go to the "Here's an easy fix" section. If you prefer to fix this problem manually, go to the "Let me fix it myself" section.

Here's an easy fix

To clear the SY00800 Batch Activity table and update the batch status in the SY00500 batch table automatically, click the Download button. In the File Download dialog box, click Run or Open, and then follow the steps in the easy fix wizard.
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you’re not on the computer that has the problem, save the easy fix solution to a flash drive or a CD, and then run it on the computer that has the problem.
 

Let me fix it myself

Easy fix 50435


Follow these steps to fix this problem yourself:

NoteAll scripts that are in the "Resolution" section must be run in a query tool. To open the appropriate query tool, follow these guidelines:
  • If you are using Microsoft SQL Server 2000, run the statement in Query Analyzer. To open Management Studio, click Start, point to Programs, point to Microsoft SQL Server 2000 and then click Query Analyzer. To run a script, click New Query.
  • If you are using Microsoft SQL Server 2005, run the statement in Microsoft SQL Server Management Studio. To open Management Studio, click Start, point to Programs, point to Microsoft SQL Server 2005 and then click SQL Server Management Studio. To run a script, click New Query.
  • If you are using Microsoft SQL Server 2005 Express, run the statement in Microsoft SQL Server Management Studio Express. To open Management Studio Express, click Start, point to Programs, point to Microsoft SQL Server 2005 and then click SQL Server Management Studio Express. To run a script, click New Query.
  • If you are using Microsoft SQL Server 2008 (and later versions of SQL), run the statement in Microsoft SQL Server Management Studio. To open Management Studio, click Start, point to Programs, point to Microsoft SQL Server 2008 (or the version you have) and then click SQL Server Management Studio. To run a script, click New Query
To run the script, follow these steps:
  1. Make sure that you have a current backup of the company database, and ask all users to exit Microsoft Dynamics GP. To create the backup in Microsoft Dynamics GP, follow the appropriate steps after all users log off from Microsoft Dynamics GP: 
    1. On the File menu, click Backup.
    2. In the Company Name list, click the company that you want to back up.
    3. In the Select the backup file box, click the yellow folder to open the location in which you want to put the backup file.

    Or
    1. In the Object Explorer, Expand your databases so you see the database you want to back up.
    2. Right click the Database Name, go to Tasks, and select Backup.
    3. Click the add button and select the location and file name you wish to save your backup to.
    4. Click Ok to start the backup.
  2. View the contents of the following tables to verify that all users are logged off: DYNAMICS..ACTIVITY, DYNAMICS..SY00800, DYNAMICS..SY00801, TEMPDB..DEX_LOCK, and TEMPDB..DEX_SESSION. To do this, run the following script.
    SELECT * FROM DYNAMICS..ACTIVITY
    SELECT * FROM DYNAMICS..SY00800 
    SELECT * FROM DYNAMICS..SY00801 
    SELECT * FROM TEMPDB..DEX_LOCK 
    SELECT * FROM TEMPDB..DEX_SESSION
    Note When all users are logged off from Microsoft Dynamics GP, these tables will not have any records in them.
  3. If no results are returned, go to 'Step 4'. Otherwise, clear the stuck records by using any of the following appropriate scripts.
    DELETE DYNAMICS..ACTIVITY 
    DELETE DYNAMICS..SY00800 
    DELETE DYNAMICS..SY00801 
    DELETE TEMPDB..DEX_LOCK 
    DELETE TEMPDB..DEX_SESSION
  4. Run the following script against the company database. Replace XXX with the batch number or the name of the batch that you are trying to post or select in Microsoft Dynamics GP.
    UPDATE SY00500 SET MKDTOPST=0, BCHSTTUS=0 where BACHNUMB='XXX'
    Note The value of BACHNUMB is the same as the value of the Batch ID window in Microsoft Dynamics GP.
  5. Verify the accuracy of the transactions.
  6. Verify that you can edit and post the batches.
Note For more information about Payroll check interruptions, click the following article number to view the article in the Microsoft Knowledge Base:
 
851664 Error message when you select a batch in the Build Payroll Checks window in Microsoft Dynamics GP
 

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References

For more information about the steps to install Support Administrator Console, click the following article number to view the article in the Microsoft Knowledge Base:

870052 How to install the Support Administrator Console utility in Microsoft Dynamics GP

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More Information

Query Words: 18374 mssql release 850289

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Keywords: kbcip, kbfixme, kbmsifixme, kbmbspilot, kbmbsmigrate, kbfreshness2007, kbprb, kbtshoot, kb, kbmbsgp10,, kbmbspartner

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Article Info
Article ID : 850289
Revision : 4
Created on : 6/6/2018
Published on : 6/6/2018
Exists online : False
Views : 638