Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"An invalid directory pathname was passed" error message when you use Active Directory Users and Computers to view user properties in Windows Server 2003


View products that this article applies to.

Symptoms

In Microsoft Windows Server 2003, you can use the Active Directory Users and Computers snap-in to view the properties of a user. However, when you click the Members tab in the Properties dialog box for a particular user, you receive an error message that is similar to the following:
An invalid directory pathname was passed.

↑ Back to the top


Cause

This problem may occur if the all the following conditions are true:
  • The user is a member of a group that has a forward slash character (/) in the group name.
  • You install the hotfix that is described in the following Microsoft Knowledge Base (KB) article:
    833883 You cannot view a user's Universal Group membership in Windows Server 2003 Active Directory Users and Computers when Universal Groups do not reside in the local domain
  • You edit the AlwaysShowExternalGroups subkey as directed in KB article 833883.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date 		Time 	Version 	Size 	  File name
------------------------------------------------------------ 
10-Jun-2004	17:09 	5.2.3790.182 	760,320   Adprop.dll

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: KB842632, kbwinserv2003presp1fix, kbfix, kbbug, kbhotfixserver, kbqfe, kbautohotfix

↑ Back to the top

Article Info
Article ID : 842632
Revision : 11
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 523