Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Exchange Server 2003 Recipient Update Service continually updates some recipients or public folders with random SMTP proxy addresses


View products that this article applies to.

Symptoms

The Microsoft Exchange Server 2003 Recipient Update Service continually updates some recipients or public folders with what appear to be random SMTP proxy addresses. Additionally, you experience the following symptoms:
  • The number of SMTP proxy addresses may continue to increase.
  • The performance of Windows domain controllers may decrease.
  • The processor usage of Lsass.exe may be close to 100%.

↑ Back to the top


Cause

Because of particular configurations of recipient policies, the Recipient Update Service may not be able to recognize addresses as valid. Therefore, the Recipient Update Service will continue to stamp the addresses with additional random SMTP proxy addresses. The most common cause is a change to the default recipient policy, such as using %g.%s wildcards instead of %m wildcards. If %g.%s wildcards are used, non-user objects that do not use the given name and surname attributes, such as resource mailboxes and public folders, are evaluated incorrectly when the recipient policy is applied.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date          Time    Version       Size     File name
   --------------------------------------------------------
   13-Feb-2004   03:03   6.5.6980.69   65,536   Inproxy.dll      

↑ Back to the top


Workaround

To work around this issue, use either of the following methods:
  • Create specific, higher priority recipient policies to create alternative SMTP proxy addresses for user objects only.
  • Correct the default recipient policy so that it no longer uses attributes that are not present on non-user objects. For additional information about modifying the SMTP proxy address, click the following article number to view the article in the Microsoft Knowledge Base:
    822447� How to Modify an SMTP e-mail address by using recipient policies

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
817903� New naming schema for Exchange Server software update packages

↑ Back to the top


Keywords: KB834349, kbexchange2003presp1fix, kbbug, kbfix, kbqfe, kbhotfixserver, kbautohotfix

↑ Back to the top

Article Info
Article ID : 834349
Revision : 7
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 408