Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: "Error HTTP 503: The Service is unavailable" error when the connection to the UAG trunk fails in Forefront Unified Access Gateway 2010 Service Pack 4


View products that this article applies to.

Symptoms

Client connections to the Microsoft Forefront Unified Access Gateway (UAG) 2010 Service Pack 4 (SP4) trunk for published applications may fail, and the client receives the following error message:

Error HTTP 503

The Service is unavailable.


Additionally, you may find intermittently logged Application log errors that are related to an application fault for Internet Information Services (IIS) worker process. These errors resemble the following:

Faulting application name: w3wp.exe, version: 7.5.7601.17514, time stamp: 0x01234567
Faulting module name: KERNELBASE.dll, version: 6.1.7601.18409, time stamp: 0x76543210
Exception code: 0xc0000005
Fault offset: 0x000000000000940d
Faulting process id: 0x1234
Faulting application path: c:\windows\system32\inetsrv\w3wp.exe
Faulting module path: C:\WINDOWS\system32\KERNELBASE.dll

↑ Back to the top


Cause

This problem occurs because of incorrect connection handling in the UAG Whlfilter.dll file.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


References

Learn about the terminology that Microsoft uses to describe software updates.

↑ Back to the top


Keywords: kbqfe, kbsurveynew, kbnotautohotfix, kbfix, kbexpertiseinter, kbbug, kb

↑ Back to the top

Article Info
Article ID : 3070067
Revision : 1
Created on : 1/7/2017
Published on : 6/19/2015
Exists online : False
Views : 255