Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: "Root element is missing" error occurs when messages are retried to send to FTP server in BizTalk Server 2010


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You use Temporary Folder in an FTP send port in Microsoft BizTalk Server 2010.
  • You select the Ordered delivery and Enable routing for failed messages options in the Transport Advanced Options page for the FTP send port.
  • You set the value of Representation as binary in the FTP Transport Properties dialog box for this FTP send port.
In this scenario, certain messages cannot be transferred to the FTP server intermittently. Additionally, you receive the following error message:
The adapter failed to transmit message going to send port "<SendPortName>" with URL "<FTPAddress>". It will be retransmitted after the retry interval specified for this Send Port. Details:"The remote server refused a data connection.Please check permissions on the remote system. "
After you receive the previous error message, messages are retried to send to the FTP server as per the send port settings. During the retry, you receive the following error message:
The adapter failed to transmit message going to send port "<SendPortName>" with URL "<FTPAddress>". It will be retransmitted after the retry interval specified for this Send Port. Details:"An unexpected failure occurred when processing a message. The text associated with the exception is "Root element is missing.". "
Then, messages are routed to the delivery failure location.

Note This issue has been already resolved in Microsoft BizTalk Server 2013 and BizTalk Server 2013 R2.

↑ Back to the top


Cause

The issue occurs because the retry in binary mode confuses the disassembler. Therefore, the "Root element is missing" error occurs.

↑ Back to the top


Resolution

Cumulative update information

This issue was first fixed in the following cumulative update of BizTalk Server:

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseadvanced, kb

↑ Back to the top

Article Info
Article ID : 3021232
Revision : 1
Created on : 1/7/2017
Published on : 4/7/2015
Exists online : False
Views : 388