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FIX: "Device in use" error when you try to establish a TN3270 print session


View products that this article applies to.

Symptoms

When you try to establish a TN3270 print session through the Microsoft Host Integration Server 2013 TN3270 service, you may receive the following error message:
Device in use

A TN3270 trace that's captured through the SNA Trace utility contains the following, more-detailed error message:

SUBNEG BEGIN TN3270E DEVICE-TYPE REJECT

This issue may occur even if the session is displayed as available in the Host Integration Server Admin Console.

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Cause

Under certain race conditions, a repeating 1-second timer is started before the session is cleaned up. This prevents a new session for the logical unit from being established immediately.

The hotfix in the "Resolution" section changes the timer so that the session ends immediately. This allows for the immediate establishment of a new session for the logical unit.

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Resolution

Microsoft Host Integration Server 2013

The fix that resolves this issue is included in the following cumulative update:

Cumulative Update 3 for Host Integration Server 2013

Hotfix for Cumulative Update 2 for Host Integration Server 2013

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website:

Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have cumulative update package 2 for Microsoft Host Integration Server 2013 installed to apply this hotfix. For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2929767 Cumulative update package 2 for Host Integration Server 2013

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, atdownload, kb

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Article Info
Article ID : 3021089
Revision : 1
Created on : 1/7/2017
Published on : 9/30/2015
Exists online : False
Views : 310